Spotlight broken- how to debug?

Discussion in 'macOS' started by DreadPiratePete, Sep 1, 2005.

  1. DreadPiratePete macrumors newbie

    Joined:
    Aug 31, 2005
    #1
    Hi all! This is my first post, so go easy on me.

    About a month ago I installed Tiger on my 15" Powerbook. Its amazing. I love it. However, a few days ago, Spotlight stopped working. I type into the search bar and nothing happens. Zero. Nada. Zip. This had worked great for about a month.

    I'm wondering if anyone knows any debugging tips. I'm a fairly competent software engineer, and am very familiar with Unix, so does anyone have any starting points? Looked in the console, shows nothing of interest.

    Thanks!
     
  2. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #2
    Last reboot? There should be a process called "mds" running. This is responsible for all Spotlight searches. If the process isn't running, that would explain why Spotlight isn't working.
     
  3. Mitthrawnuruodo Moderator emeritus

    Mitthrawnuruodo

    Joined:
    Mar 10, 2004
    Location:
    Bergen, Norway
    #3
    Welcome to the forums! :)

    I would first try to re-index Spotlight.

    If that doesn't work, you can go on to the regular tips (;)):
    - Deleting the Spotlight preference file ~/Library/preferences/com.apple.spotlight.plist. Corrupt preference files are often culprits when an application stops working).
    - Repairing permissions (Can be done by running sudo diskutil repairPermissions / from Terminal, or by using Disk Utility, or a third party application like MainMenu. Faulty permissions also have been known to cause problems.
    - Check if Spotlight is working on another user account on your Mac. Make another account if needed. If it works there we've narrowed it down to something in your account.

    Happy hunting! :)
     
  4. DreadPiratePete thread starter macrumors newbie

    Joined:
    Aug 31, 2005
    #4
    Thanks...

    Thanks for the quick replies. I created a test account, spotlight isn't working there either. I checked for the process "mds" and can't find it. Can't even find it on the disk, using locate. I'm assuming that mds is the problem. I'll try repairing permissions and see if that helps. Thanks!

    /kurt
     
  5. DreadPiratePete thread starter macrumors newbie

    Joined:
    Aug 31, 2005
    #5
    Worked!

    IT WORKED! Fixing permissions seems to have done the trick. I noticed there was a bunch of directories in /private/var/tmp/mds called 501 and 502 that had what seemed to be lock files in them. Was tempted to delete, but figured I'd try the Fix Permissions thing first. It seemed to crank through a lot of things, so I rebooted after. Came back up licketity split (faster than before), and spotlight now seems to be re-indexing everything (I'm assuming that's a good thing). The 'mds' process also appears to be running now.
    My mac also seems to be running a LOT faster now. Is that related, or in my head?

    Thanks a ton!

    /kurt

    [Random words to help other people searching]

    Spotlight doesn't work broken busted no results mds repairPermissions corrupt preference file diskutil
     
  6. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #6
    No problem.

    501 and 502 are likely the UIDs of previous user accounts on the Mac that probably have been removed.
     

Share This Page