1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Spotlight Crashing/Running forever/mdworker crashing

Discussion in 'OS X Mountain Lion (10.8)' started by sososowhat, Sep 30, 2012.

  1. macrumors 6502

    #1
    I'm running a Macbook Pro, 10.8.2, 8 Gig, 120Gig OWC SSD. All was fine (no recent system changes though maybe Software Update did something). Then a few days ago Spotlight started running forever, never even getting past Estimating indexing time.

    Looking at the system log, mdworker seems to be crashing constantly. I've seem a number of other similar threads here & on Apple Support, but no one seems to have pointed out mdworker crashing or come up with a definitive solution.

    HELP!
     

    Attached Files:

  2. macrumors 6502

    #2
    Can anyone help with this? I've had to turn Spotlight off & that really sucks.

    Suggestions, particularly brilliant inspired knowledgeable suggestions, would be greatly appreciated!
     
  3. macrumors 6502

    #3
    Have you tried starting your spotlight index over from scratch?

    sudo mdutil -E /
     
  4. macrumors 68020

    Xavier

    #4
    Spotlight has been indexing a lot more often then it used to for me but I haven't thought anything of it really.
     
  5. macrumors 6502

    #5
    Well, something I've done seems to have worked! I tried the mdutil -E as suggested, & toggled with -i on as well & now things seem to be working (though won't know for sure till it's done & I've got 6 hours remaining on the rebuild on a 120Gig SSD, which seems mighty slow to me).

    It could have been something else, but I think it may well have been the mdutil magic. Thanks thirdeye for the suggestion!
     
  6. macrumors 6502

    #6
    Ok, no -- the problem's back & no combination of mdutil flags & reboots seems to be helping it. Spotlight running forever, never getting past estimating time. PID 0 using 20% of the CPU. Fans spinning.

    Anyone?
     
  7. macrumors 6502

    #7
    Here's what I'm finding by running Console:
     

    Attached Files:

  8. macrumors 6502

    #8
    Dang. Wish that had worked. It could be a bad sata cable... Or even a bad drive. I'd probably try a clean install before assuming it was hardware though.
     
  9. macrumors 6502

    #9
    Ok, solved I think. It had nothing to do with Spotlight per se: There was some corrupt file in one user account. The finder hung trying to copy that directory as I was preparing to do a clean install. Disk Utility couldn't repair it and suggested I backup what I could & reformat the disk. However: after I removed the one user account, spotlight runs fine (just finished after 90 minutes or so) & Disk Utility was able to repair the disk.

    Definitely not very helpful behavior on the OS's part (Spotlight hangs, file-copy hang, Disk Utility throwing up its hands), but I'm happy to have it all working again. Hopefully permanently.
     

Share This Page