Spotlight in Lion - Only Displays Web Searches, no real results?

Discussion in 'Mac OS X Lion (10.7)' started by victorhooi, May 30, 2011.

  1. macrumors newbie

    Joined:
    Mar 29, 2011
    #1
    heya,

    I have Lion DP3 installed, and my Spotlight seems to be acting up.

    Basically, it won't show any results except for Web Searches.

    The exception to this, for some weird reason is a USB key I've inserted that it's now decided to index - i.e. it will find files from there.

    However, it won't show any of my applications or documents from my main system drive. I've checked Spotlight Preferences, all of the categories are ticked, and Privacy doesn't have any drives/folders excluded.

    I've tried suggestion 2 and 4 from here:

    http://osxdaily.com/2007/02/15/spot...otlight-menu-with-these-troubleshooting-tips/

    Code:
    sudo mdutil -E /
    Password:
    /:
    	No index.
    Doesn't seem to show indexing in the Spotlight menu, nor do any results appear after waiting.

    I've also tried downloading MainMenu, and using "Rebuild Spotlight Indexes" and "Clear All User Caches", "Clear System Caches" and "Clear Font Caches", no effect.

    Has anybody else encountered this issue? Any other way to fix it?

    Spotlight is very awesome, definitely miss it...lol.

    Cheers,
    Victor
     
  2. macrumors G3

    Joined:
    Jul 23, 2002
    Location:
    Sol III - Terra
    #2
    I think there is one thing you haven't tried.

    Add the volumes that won't index to the privacy list to disable searching on those volumes in spotlight preferences.

    Then remove the .Spotlight-V100 folder in the root of each volume you disabled spotlight on.

    Restart your system.

    If the volumes are still marked to be not searched in spotlight preferences, remove them from the privacy list.

    This has cleared spotlight issues in the past.
     
  3. macrumors newbie

    Joined:
    Jul 6, 2011
    #3
    Same problem here

    I am having the same problem. Spotlight results from my HD drive connected to were the superdrive used to be are compretelly random. I have tried to rebuild the spotlight index in both volumes, fix permissions, clear caches, etc. to no avail. Help please!
     
  4. Nero Wolfe, Jul 6, 2011
    Last edited: Jul 6, 2011

    macrumors regular

    Nero Wolfe

    Joined:
    Oct 28, 2007
    Location:
    Atlanta, GA
    #4
    I, too, am having this problem. Sometimes I get the folder or file I'm searching for, but usually I just get PDFs or websites. The results I should be getting will display in 'Show All in Finder'. I've tried reordering the display options in Sys Prefs, but it still won't show certain things in the Spotlight Menubar drop down. So odd. I haven't tried deleting and reindexing yet because one of the Volumes affected is HUGE (TBs) and I don't want wait while it does all that.

    Edit: Hmm... seems like it might be just the external volumes that it's doing this with... I wonder if maybe because there is an older 10.6-created Spotlight index already on there...
     
  5. macrumors member

    Joined:
    Feb 7, 2011
    Location:
    philly, PA
    #5
    I am also having the exact same problem with all the same symptoms. I am contemplating just giving up and taking it to apple.
     
  6. macrumors newbie

    Joined:
    Aug 16, 2011
    #6
    Spotlight not indexing system applications

    Your user has an applications folder.
    The operating system has an applications folder.

    Spotlight isn't looking in the os applications folder, only in your user folder.

    1. Go to the root directory of your hard drive.
    2. Create an alias for the Applications folder.
    3. Drag that alias into the application folder for your user.

    Spotlight will now find all applications in that folder and in your own user applications folder.
     

Share This Page