SSD detected as HDD by OS X

Discussion in 'MacBook Air' started by Chris155, Feb 20, 2013.

  1. macrumors newbie

    Joined:
    Feb 20, 2013
    #1
    I'm having some problems with a new SSD in a mid 09 1.86ghz macbook air.

    I installed it and everything went ok until I checked for trim support (running 10.6.8), found out that Mac OS X has mistakenly identified the SSD as a conventional HDD and therefore won't enable trim. I did a clean install, smc and pram resets, even tried running Lion but I'm having the same problem. I know the SSD supports trim since I tried with Windows 7 on bootcamp and it reports it as enabled.

    This is what System Profiler reports of the SSD (it's an apple toshiba unit)


    NVidia MCP79 AHCI:

    Vendor: NVidia
    Product: MCP79 AHCI
    Link Speed: 3 Gigabit
    Negotiated Link Speed: 1.5 Gigabit
    Description: AHCI Version 1.20 Supported

    APPLE SSD TS128:

    Capacity: 125.5 GB (125,500,104,704 bytes)
    Model: APPLE SSD TS128
    Revision: A0985002
    Serial Number: 01J850005045
    Native Command Queuing: No
    Removable Media: No
    Detachable Drive: No
    BSD Name: disk0
    Medium Type: Rotational
    Partition Map Type: GPT (GUID Partition Table)
    S.M.A.R.T. status: Verified


    Is there any way of fixing this?
     
  2. macrumors 6502

    Joined:
    Nov 27, 2011
    Location:
    Long Island/North Jersey
    #2
    Maybe try verifying disk? I fond it odd that it comes up as a TS128 but says rotational? Its almost like the SSD itself doesn't know its an SSD
     

Share This Page