SSH Problems in Tiger

Discussion in 'macOS' started by ferrisb, Jun 28, 2005.

  1. ferrisb macrumors member

    Joined:
    Jun 23, 2003
    Location:
    Riverton, Utah
    #1
    Since upgrading to Tiger, I haven't been able to SSH from the Terminal into my Mac at home.

    Both machines are running 10.4.1, and before Tiger it worked fine.

    When I try to connect, I'm asked for a password, but then it seems to hang for a minute or two before I get a "Disconnecting: Bad packet length 2698077874" error, with the last number always being different.

    Anybody have any ideas as to what the problem might be, or have you experienced the same problem?
     
  2. tag macrumors 6502a

    tag

    Joined:
    Apr 29, 2005
    Location:
    PA, US
    #2
    I personally haven't run into this problem, but on macosxhints there was someone that had, he found these solutions to the problem

    Snippet below from http://www.macosxhints.com/article.php?story=20010621170443810

    the 10.4 update makes ssh use ssh2 by default instead of ssh1, and since many people use ssh1 this might end up with problems like:

    Disconnecting: Bad packet length -1483636419.

    when trying to connect to a host with sshd version 1.
    to fix this:
    1) force ssh to use protocol 1
    ssh -1 user@serverhost
    2) edit /etc/ssh_config
    change: "# Protocol 2,1"
    to: " Protocol 1,2"
    3) upgrade sshd on serverhost to version 2

    I haven't actually tried this myself since I haven't experienced this problem, but maybe this will fix it or help point you in the right direction.
     
  3. ferrisb thread starter macrumors member

    Joined:
    Jun 23, 2003
    Location:
    Riverton, Utah
    #3
    I saw that hint while I was searching for a solution, and it's actually talking about 10.0.4, not 10.4.

    Both machines I'm trying to connect are running 10.4, so I don't think that would be the issue.

    Just for giggles, I tried what they mentioned, and that didn't fix the issue, so I'll have to keep looking.

    Thanks for the suggestion though.
     
  4. superbovine macrumors 68030

    superbovine

    Joined:
    Nov 7, 2003
    #4
    you could try and download and recompile ssh for os x.
     
  5. Westside guy macrumors 601

    Westside guy

    Joined:
    Oct 15, 2003
    Location:
    The soggy side of the Pacific NW
    #5
    Boy this really looks like the error that results from trying to connect to a SSH1 daemon from an SSH2 box. I know you said you're trying to connect to another 10.4 box - are you typing in the whole address w/o any shortcuts?

    Basically I'm wondering if you are not getting to the box you think you're getting to.

    BTW you do NOT want to switch that "Protocol" line - if you use protocol 1 your encryption is breakable.
     
  6. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #6
    You should be using the -v flag (or -vv) with ssh to lend some verbosity to your problem.
     
  7. BornAgainMac macrumors 603

    BornAgainMac

    Joined:
    Feb 4, 2004
    Location:
    Florida Resident
    #7
    Try renaming your .ssh directory in your home directory to something else like .ssh_backup. Perhaps the configuration file in that directory works with the older version of ssh. When you connect, it will set itself up again.
     
  8. ferrisb thread starter macrumors member

    Joined:
    Jun 23, 2003
    Location:
    Riverton, Utah
    #8
    I got it working - thanks for the help everyone. Although the solution is really embarrassing now.

    I didn't capitalize the first letter of my username. As soon as I did, everything worked like a charm.

    STUPID! STUPID! STUPID! STUPID! ...
    :eek:
     
  9. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #9
    Your short username uses capitals? That's odd.
     

Share This Page