ssh problems

Discussion in 'macOS' started by forbade, May 9, 2006.

  1. forbade macrumors member

    forbade

    Joined:
    Mar 31, 2006
    Location:
    US
    #1
    Im trying to ssh to one of my computers on my network.

    but when I try to ssh, it spits this out.

    "Last login: Tue May 9 09:26:16 2006 from 10.0.1.3

    Welcome to Darwin!
    HOME-COMP:~ w00t$ ssh n@10.0.1.4
    n@10.0.1.4's password:
    Permission denied, please try again.
    n@10.0.1.4's password:
    Permission denied, please try again.
    n@10.0.1.4's password:
    Permission denied (publickey,password,keyboard-interactive)."

    I know the password, but whenever I put it in it says permission denied.
    Nothing more annoying than knowing a password, and then it says permission denied.


    what makes it even more annoying, is that it will allow me to ssh to 10.0.1.3, no problemo.
    but if I try to ssh from 10.0.1.3 - 10.0.1.4 it wont let me???


    Any help is appreciated.
     
  2. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #2
    Well, if you're sure it's the correct password, then it could be that the account 'n' either has no shell to log into, or that it was disallowed in /etc/sshd_config. However, how sure are you that the password is correct? Can you log into the console on that box with that password?
     
  3. forbade thread starter macrumors member

    forbade

    Joined:
    Mar 31, 2006
    Location:
    US
    #3
    Yes, I can log into the account with the password.

    So its probably the sshd_config file. Ill go check it out right now.
    Thanks yellow. I appreciate your help.:again:. lol
     
  4. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #4
    Ahh.. did you perhaps use fink to install a 'newer' version of ssh on 10.0.1.3?
     
  5. forbade thread starter macrumors member

    forbade

    Joined:
    Mar 31, 2006
    Location:
    US
  6. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #6
    I thought as much..

    Try this then:

    /usr/sbin/ssh n@10.0.1.4

    And see if it works.. I bet it will.
     
  7. forbade thread starter macrumors member

    forbade

    Joined:
    Mar 31, 2006
    Location:
    US
  8. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #8
    Once again, you were reinventing the wheel? :) Your Mac has most common UNIX binaries installed. Make sure you check /usr/bin, /usr/sbin/, /sbin, and /bin first.

    Then I would investigate the error logs on 10.0.1.4 to see what in the fink version of ssh was doing "wrong" (or right) that the default version of ssh that comes with Mac OS X (OpenSSH_3.8.1p1, OpenSSL 0.9.7i 14 Oct 2005) didn't like. There may be some flags you can use to make it work with the fink version.
     
  9. forbade thread starter macrumors member

    forbade

    Joined:
    Mar 31, 2006
    Location:
    US

Share This Page