Starbucks app problem

Discussion in 'iOS Apps' started by eagleglen, Jan 25, 2011.

  1. eagleglen, Jan 25, 2011
    Last edited: Jan 26, 2011

    macrumors 6502a

    Joined:
    Oct 2, 2009
    Location:
    San Diego, CA
    #1
    Hello,

    Is anyone else having problems loading credit onto your Starbucks card using the new Mobile Card App? This is so you can start using your iPhone to pay your Starbucks bill. I go to reload card, select amount, payment type, continue, and then confirm. Long pause and then a communication error. And the balance remains unchanged. I've deleted and reinstalled the app. Tried using both wifi and 3G. Deleted my card info and re-entered. Been trying for over a day. Still no success.

    Has anyone else had a similar problem, or better yet, solved the problem? A SB cashier can load your card for you, but there is a promotion currently for a $5 bonus if you load your card using the app with a Visa the first time, so I'd really like to get this to work. Thanks for any help you can offer.

    ------------------------------ An Update--------------

    WARNING!!!!!!

    Every attempt I made to reload my card resulted in a debt charge to my account. During the night, Starbucks processed the charges and now my account has been charged $875!!! After I pressed conformation on the app, the warning I got said there was a communication error and that I should refreash my balance. Since my balance never changed, it said to retry the transaction, which I foolishly did. Please be warned. Currently on the phone now with my bank and Starbucks for a resolution.
     
  2. macrumors regular

    Joined:
    Jul 1, 2010
    Location:
    Washington, DC
    #2
    Try using a different starbucks card and see it if works. You can have more than one card using the app and still earn your stars. I've been using the app for about 3 months now and it works fine for me.
     
  3. macrumors newbie

    Joined:
    May 2, 2011
    #3
    Not an isolated incident

    My dd has had the same problem, multiple times. She's ready to stop using the app all together.
     
  4. macrumors newbie

    Joined:
    Oct 17, 2012
    #4
    I had that problem, I managed to fix it by going into my passbook and deleting the card, closing the starbucks app and reopening it and everything reloaded properly.
     
  5. macrumors 68040

    TWO2SEVEN

    Joined:
    Jun 27, 2010
    Location:
    Plano, TX
    #5
    :eek:

    This happened to me, luckily it was only two $10 charges.

    I hope you get it worked out.
     
  6. macrumors 68000

    Sital

    Joined:
    May 31, 2012
    Location:
    New England
    #6
    I'm sure he did by now. :rolleyes:
     
  7. macrumors 68040

    TWO2SEVEN

    Joined:
    Jun 27, 2010
    Location:
    Plano, TX
    #7
    What a useless comment. So sorry I overlooked the original posting date since this was at the top of the sub forum. :rolleyes:
     
  8. Aaa.lll, May 15, 2013
    Last edited: May 15, 2013

    macrumors newbie

    Joined:
    May 15, 2013
    #8
    Sudden balance lost on my card

    I loaded my card last Sunday for amount amount of $10 and this morning I purchased a tall Pike. Now the stupid app shows my balance is zero.
    A tall size Pikeplace cost me 10 freaking dollars. This is just a rip off. Has anyone else had experienced a similar issue.
    I have to add that my history shown on the app is also my evidence/ proof.
    Conclusion: I am not reloading my card anymore and I will not recommend paying using the Starbucks app. Who knows how much extra I have been charged for every drink I have bought
    I have send a similar message to customer service and expecting them to reply.
     
  9. macrumors 68040

    braddick

    Joined:
    Jun 28, 2009
    Location:
    Encinitas, CA
    #9
    Keep in mind too Starbucks rewards your iPhone app a single star for each purchase, not for each item.
    For example, if you order three lattes and pay via the app you receive one star.
    If you paid for each one separate, you would receive three star rewards.
     
  10. macrumors newbie

    Joined:
    May 29, 2015
    #10
    Heads Up, This just happened to me too. What crap! $80! I just sent them an email; I better get that money refunded to me...
     

Share This Page