Starcraft 2 Crashes @ Start

Discussion in 'Mac and PC Games' started by moodselektor, Jul 8, 2011.

  1. macrumors newbie


    Oct 26, 2008
    I am so upset. I have tried everything!

    I repaired the disk permissions.

    I deleted the .plist files in my ~/Library/Preferences/ folder.

    I also reinstalled the game. That didn't do a thing.

    I ran an extended hardware test and it seems that I have no problems with the hardware.

    I thought it may be something to do with the 10.6.8 update, so I installed the snow leopard and updated to 10.6.7 and it didn't help!

    I contacted the Blizzard support and they keep sending me pre written suggestions that are useless.


    I am posting to various tech forums, so may be there is someone who can help me fix the issue!
  2. macrumors newbie

    Jul 6, 2011
    Cork, Ireland.
    Sorry if Blizz Tech support already suggested this, but did you try running the SC2 Repair tool?

    Otherwise, you could open a "My Support Site" ticket at and specifically ask for a Mac Tech Support rep to handle your issue (most of them would be Windows only).
  3. macrumors regular

    Sep 6, 2006
    I don't know the system specs for your computer but I had the same problem with my older 24" imac as well. I noticed that the video card in the imac did not meet the minimum requirements for the game. The game would start up fine and seemed to run ok for a min or so but then it would crash. Don't know if this is the same as your case but thought I would share just in case.

Share This Page