Starcraft Online Help

Discussion in 'Mac and PC Games' started by patmort02, May 26, 2007.

  1. macrumors member

    Joined:
    Mar 2, 2006
    #1
    My brother and I both own copies of starcraft and would like to play against each other. We both sign in to battlenet and try to play against each other but when joining the game it says the host's latency is too high. We have both tried hosting games, but to no avail. We are both on my home network, so I'm not sure why the latency would be higher for one and not the other.

    Does anybody have any ideas as to why this isn't working?
     
  2. macrumors newbie

    Joined:
    May 30, 2007
    Location:
    NoVA
    #2
    I have this problem happen to me before. I believe I just had to settle for a LAN game. if not it may or may not be because of how your network is set up. I don't think B.net recognizes two accounts on the same network. maybe someone else can enlighten me on how that works.
     
  3. macrumors 6502

    Joined:
    May 14, 2007
    Location:
    Waterloo, ON
    #3
    I had a similar problem, 2 people could join the game, but when the third tried to join, we all disconnected from b.net.
    we solved it by opening different ports for each computer.
    6112, 7112, 8112 etc.
     
  4. Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    Whakatane, New Zealand
    #4
    Yeah, if you're just trying to play against each other with no more players, just choose UDP/IP and play using that. You'll have pings in the single digits :)
     

Share This Page