Steam Help - offline mode

Discussion in 'Mac and PC Games' started by MrBean, Nov 27, 2010.

  1. macrumors member

    Joined:
    Nov 10, 2008
    #1
    Okay,
    So I stuck my steam in offline mode when I took my MBP to my inlaws since they don't have internet. Now when trying to get into any game, a popup comes up and says, "Steam needs to be in online mode to update, but was set to offline mode"

    Now I have found no way to place Steam back in online mode to have it update. Even re-installing the client didn't help.
     
  2. macrumors 6502a

    bokdol

    Joined:
    Jul 23, 2002
    Location:
    VA
    #2
    with steam open go under account. the drop down menu well say "go online", and it will restart steam online.
     
  3. thread starter macrumors member

    Joined:
    Nov 10, 2008
    #3
    That's the thing, I can't get steam to open. The dialog is a popup box with no options for Steam preferences or anything from the drop down menu.
     
  4. macrumors 6502a

    bokdol

    Joined:
    Jul 23, 2002
    Location:
    VA
  5. macrumors newbie

    Joined:
    Jul 14, 2007
    Location:
    Uppsala, Sweden
    #5
  6. macrumors 6502a

    bokdol

    Joined:
    Jul 23, 2002
    Location:
    VA
    #6
    have you guys tried to delete steam and redownload the installer?
     
  7. macrumors newbie

    Joined:
    Dec 7, 2010
    #7
    I don't know whether you fixed this or not but I had the same problem and was able to fix it as follows:

    1. Go to Users->%your_account%->Library->Application Support->Steam
    2. Open registry.vdf using a text editor like TextEdit
    3. This is basically the registry hive Steam uses in Windows. Go to the Registry->HKCU->Software->Valve->Steam->Offline key
    4. Change the value from "1" to "0".
    5. Save and close registry.vdf
    6. Start Steam. It should now update itself.

    Remember to change Steam back to Offline mode if so required.

    Hope this helps!
     
  8. macrumors newbie

    Joined:
    Jun 24, 2010
    #8
    Genius! You totally nailed it!

    It's a stupid bug though...
     
  9. macrumors newbie

    Joined:
    Dec 25, 2010
    #9
    so how do i get to step one?

    i have no idea what im doing...

    gah
     
  10. macrumors newbie

    Joined:
    Sep 26, 2009
    Location:
    Copenhagen, Denmark
    #10
    Works like it should, much appreciated :)
     
  11. macrumors 6502a

    deadwulfe

    Joined:
    Feb 18, 2010
    #11
    Open a Finder window.
     
  12. macrumors newbie

    Joined:
    Apr 9, 2011
    #12
    Thank You

    Bugu you are awesome. Thank you for the very clear explanation of how to change the value of the offline rule. It took under a minute to solve a problem that I worked for days to try to figure out.
     
  13. macrumors member

    Joined:
    Sep 25, 2010
    #13
    Go to Users->%your_account%->Library->Application Support->Steam

    im a new mac user, currently running lion
    where can i find this??? i cant find user, and i did a search in finder for steam, registry.vdf, etc and cant find anything...
     
  14. macrumors 6502a

    deadwulfe

    Joined:
    Feb 18, 2010
    #14
    Double check switching to Offline mode without the internet. It works for me, under Windows and Mac OSX without fiddling around with files to be able to go to Offline mode without being connected to the internet. Try it first before you start mucking things up.
     
  15. macrumors newbie

    Joined:
    Sep 20, 2011
    #15
    I'm portuguese and I don't know how to go to the first thing told "users" .
    can you please help me ?
     
  16. macrumors 6502a

    Joined:
    Apr 1, 2007
    #16
    What are you trying to do?

    It means /Users/ that is the folder Users in the root of your HD. It might be named something like Usuários if you have Portuguese locale enabled.
     
  17. macrumors member

    Joined:
    Sep 14, 2011
    Location:
    Victoria, Australia
    #17
    The directory you refer to doesn't exist on my computer. Simple as that. Any other ideas? :confused:
     
  18. macrumors 6502a

    deadwulfe

    Joined:
    Feb 18, 2010
    #18
    It does. Macintosh HD -> Users. Just go to your home folder and look for the Library folder, then Application Support, then Steam.
     
  19. macrumors member

    Joined:
    Sep 14, 2011
    Location:
    Victoria, Australia
    #19
    After a bit more thought about this I discovered that I had to reconfigure Finder to display hidden files and folders via Terminal. It was only then that the folder appeared in Lion.

    A bit much was being "assumed" in earlier advices. Sorry - I'm a newb to Mac.
     
  20. macrumors 6502

    Joined:
    Jan 29, 2002
    Location:
    NJ
    #20
    In Lion, the Library folder is hidden. You can access this folder by opening the finder, holding down the Option (Alt) key, and clicking on the Go menu. The Library directory will be shown under this menu for you to select.
     
  21. macrumors newbie

    Joined:
    Mar 3, 2011
    #21
    When I open registry.vdf using text edit all it says is:

    "Registry"
    {
    "HKCU"
    {
    "Software"
    {
    "Valve"
    {
    "Steam"
    {
    "Language" "english"
    }
    }
    }
    }
    }


    There is nothing about an offline key, what do I do?
     
  22. macrumors newbie

    Joined:
    Nov 1, 2011
  23. macrumors newbie

    Joined:
    Apr 3, 2011
    #23
    Same here, can anyone help?
     
  24. macrumors newbie

    Joined:
    Nov 28, 2011
    #24
    Sure can, I think. I was experiencing something similar, so I kept looking. The actual words are Offline "1". That's what you are looking for, change that to "1" to a "0" and it should work. Pic below.

    http://imageshack.us/photo/my-images/10/cmcapture4y.png/
     
  25. macrumors newbie

    Joined:
    Oct 1, 2009
    #25
    Still works.

    Yay! Still works for this issue.

    Note that the first post is still correct. You should not be looking for the "Offline key" in the file. You should be looking for the key called "Offline". It was an unfortunate order of words.
     

Share This Page