Steinberg Weirdness

Discussion in 'Digital Audio' started by Infrared, Feb 10, 2010.

  1. macrumors 65816

    Infrared

    Joined:
    Mar 28, 2007
    #1
    For two weeks now I've been hoping for help from Steinberg's support
    team. In that time, I've not received a single reply to multiple requests
    sent via MySteinberg. The problem I would like help with is the one I
    described in this forum earlier:

    http://forums.macrumors.com/showthread.php?t=861601

    Today I composed a lengthy and (I thought) courteously worded further
    request for help at CUBASE.NET. Since I have become suspicious about
    the way Steinberg conduct their business, I took the precaution of making
    screenshots of the thread as it appeared after posting. Within minutes
    Steinberg deleted my posting. There is nothing offensive in it, as you can
    see for yourself:

    http://www.pixentral.com/show.php?picture=1tRQ8zxhqprY0CeTHFwewShOQLUb7
    http://www.pixentral.com/show.php?picture=1hDX11pGtDHv41LtWytD9Z4L2lm2Dx
    http://www.pixentral.com/show.php?picture=1yyl8ImyNtUPjSLGAvr1IHa463Yt

    Why would Steinberg do such a thing? It is making me suspect they are
    less than honest.
     
  2. thread starter macrumors 65816

    Infrared

    Joined:
    Mar 28, 2007
    #2
    I have received a pm which is making me reconsider what I was
    previously thinking might be the case. I certainly don't want to
    portray Steinberg's motives as malign if they are not. It's hard
    to know what to think at this point. I've sent in 3 or 4 support
    requests directly to Steinberg and I've already exchanged over
    30 emails with the shop that sold the software to me. Very little
    concrete technical information has come my way to date, but I'm
    positive that, with polite persistence, this can all be resolved.
     

Share This Page