Still no iMessage file transfer in GM build

Discussion in 'OS X Mountain Lion (10.8)' started by lancastor, Jul 15, 2012.

  1. macrumors 6502

    Joined:
    Jun 25, 2011
    #1
    File transfer (pictures etc.) in iMessage is still broken in the GoldMaster Build.

    I think iMessage is still not working in Mountain Lions Final release. :(
     
  2. macrumors 68030

    cmChimera

    Joined:
    Feb 12, 2010
    #2
    I've been able to send files in messages. I've sent pictures, and even word documents. What issue are you having?
     
  3. thread starter macrumors 6502

    Joined:
    Jun 25, 2011
    #3
    Messages on Mac doens't send or receive pictures.
     
  4. macrumors 68040

    iLog.Genius

    Joined:
    Feb 24, 2009
    Location:
    Toronto, Ontario
    #4
    Not sure if you're having a specific problem or just having an issue with sending pictures/files on Mac through iMessage overall but I had zero issues with the beta and no problems with GM - can send files over iMessage with no problems.
     
  5. macrumors 68030

    cmChimera

    Joined:
    Feb 12, 2010
    #5
    Yes it does. You may need to reinstall, or deactivate imessage and reactivate. It might be easier to diagnose if you post exactly what is going on instead of the very broad, "it doesn't work".
     
  6. macrumors member

    Joined:
    Jun 7, 2010
    #6
    I think I can explain, since I too have been having the same issue with the beta at least, I have not installed ML GM.
    Basically whenever you try to send any file, be it a picture, document, song, what have you, Messages will (at least for me) log me out of all my current accounts (in my case AIM, Gtalk, and iMessage) and then log me back in and not send the file. Also, when I try to send a file to anyone on AIM it does the same. I uninstalled the beta and iChat worked fine transferring files again. Reinstalled Messages, issue returns.
     
  7. macrumors 6502a

    Joined:
    Apr 24, 2012
    Location:
    Denver Colorado
    #7
    Works great in the GM release. I set it up and sent a message to my phone for the first time with a photo attachment.
     
  8. thread starter macrumors 6502

    Joined:
    Jun 25, 2011
    #8
    Transfers stays forever in "waiting" state. I cannot send files via Messages on Mac and I cannot receive files on Mac.

    I hope file transfer is possible in the final release of Mountain Lion.

    By the way: Logging off and re-login my iCloud Account doesn't help.
     

    Attached Files:

  9. thread starter macrumors 6502

    Joined:
    Jun 25, 2011
    #9
    So, I must completely wipe my whole system to get Messages to work? :confused:
     
  10. thread starter macrumors 6502

    Joined:
    Jun 25, 2011
    #10
    Here is a detailed error message:

     
  11. macrumors 6502

    Joined:
    Jul 11, 2011
    #11
    I was having a similar problem in iMessages Beta on Lion, but once I upgraded to Mountain Lion it started working again.
     
  12. macrumors 68040

    iLog.Genius

    Joined:
    Feb 24, 2009
    Location:
    Toronto, Ontario
    #12
    Ok. Let's be clear here. When sending files, are you using the iChat/AIM protocol or is this iMessage? For iMessage you can just drag/drop into the conversation window (don't use menu). I guess you could try and do the same thing if you're using the iChat/AIM protocol.
     
  13. thread starter macrumors 6502

    Joined:
    Jun 25, 2011
    #13
    I'm using iMessage and I'm dragging files directly into the conversation window. It worked great in DP1, DP2 and DP3. But it's broken now.
     
  14. macrumors 6502a

    Joined:
    Jul 29, 2003
    #14
    I still drag or paste images into the chat prompt and it works fine? However I did a clean install/upgrade to GM from Lion.
     
  15. macrumors 6502a

    Joined:
    Jul 3, 2012
    #15
    mine is working fine too. but i also did a clean install.
     
  16. thread starter macrumors 6502

    Joined:
    Jun 25, 2011
    #16
    I have found a temporally solution:

    1. Delete all files and directorys from /~/Library/Messages
    2. Reboot your Mac

    Now iMessages transfers files for 2-3 days. After that you have to delete the files again.
     
  17. macrumors 68040

    Joined:
    Jul 11, 2009
    #17
    It's been working all along for me on several computers without having to do this. I'd suggest checking logs when the transfers fail to see if there's anything in there that might help solve the real problem.
     
  18. thread starter macrumors 6502

    Joined:
    Jun 25, 2011
    #18
    I posted the error logfiles in this thread already.
     
  19. macrumors 68040

    Joined:
    Jul 11, 2009
    #19
    So you did. Since they mention entitlements, the errors seem to indicate some issue with sandboxing. What happens when you make a new user account?
     
  20. macrumors newbie

    Joined:
    Jan 9, 2009
    #20
    For some reason on the GM, I cannot even sign into iMessage. It worked fine for me on DP4, but as soon as I moved I have no access to using iMessage anymore.

    I have a co-worker who is in the same boat. Anyone else experiencing this?
     
  21. thread starter macrumors 6502

    Joined:
    Jun 25, 2011
    #21
    It's weird. After exactly three days you have to wipe the /Messages directory to enable file transfers again. :confused:
     
  22. macrumors 6502

    Joined:
    Jul 8, 2012
    #22
    What if you right click the file in finder, go to Share > Messages. Does it work then, or is it the same behavior?
     
  23. thread starter macrumors 6502

    Joined:
    Jun 25, 2011
    #23
    It's a "Standby" issue. Logoff and re-login and file transfer is working again after hibernation.
     
  24. macrumors newbie

    Joined:
    Oct 28, 2003
    Location:
    Chicago, IL
    #24
    I too am having this very same issue. I can't send or receive picts to Messages though it works fine in iMessage. It exhibits the same behavior that others have outlined.
     
  25. macrumors newbie

    Joined:
    Aug 2, 2012
    #25
    I also have this problem once in a while. Up until now I didn't have a workaround for it.

    Thank you lancastor for the tips.

    Hopefully they get this resolved soon. This was the very issue I was hoping they would fix once it was RTM.

    Another issue I have is that when I use facebook chat (via Jabber), there's a certain contact who never EVER shows up on Messages for mac. He can message me and I get it in facebook.com and on Facebook Messages for iPhone but it doesn't show up on Messages for Mac. I can start a conversation with him by sending him a message, but if he replies, it only goes to facebook.com and my phone. No clue about this one. I've tried deleting the jabber account and making a new one. Deleting his conversation. Restarting my computer. No luck.
     

Share This Page