"Stop plugins to save power" in Safari

Discussion in 'OS X Mavericks (10.9)' started by bully worm, Dec 29, 2013.

  1. macrumors regular

    Joined:
    Sep 17, 2009
    #1
    I thought this new feature was suppose to disable youtube videos until you click on them ala ClicktoFlash?

    I have the feature enabled but all youtube videos play instantly the moment I open them. :confused:

    I don't want to use the ClicktoFlash extension if the browser has it built in. I just can't seem to get it to work with youtube.
     
  2. macrumors member

    Joined:
    Dec 16, 2013
    #2
    isn't youtube, html5?
     
  3. thread starter macrumors regular

    Joined:
    Sep 17, 2009
    #3
    You do have the option to use html5. But even with that, it still auto plays.
     
  4. macrumors 68000

    Joined:
    Jan 13, 2011
    Location:
    Estonia
    #4
    YouTube HTML5 / MPEG-4 videos play natively, they don't use any plugins. So what's to stop here? If you hit on a Flash movie, Safari will ask for a confirmation.
    PS ClickToFlash has a killer feature - direct AirPlay of any web-embedded video! So I had to re-enable it.
     
  5. macrumors 68030

    zorinlynx

    Joined:
    May 31, 2007
    Location:
    Florida, USA
    #5
    The Safari power saver is fairly smart. It will only disable plugins if they aren't central to the content of the page.

    A video on YouTube is central content so it auto-plays it. A flash-based ad in the corner on a news website is not, so Safari power saver will kick in.

    So far it's been fairly smart in my experience and I've not had to click to play anything I actually WANT to see. :)
     
  6. macrumors 68040

    Badrottie

    Joined:
    May 8, 2011
    Location:
    Los Angeles
    #6
    I see. I noticed recently I thought it was bug or some kind of Safari is broken but I guess it is not...it is a feature! :apple:
     
  7. Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #7
    I never understood the logic, sometimes I'd see it do that, other times on a similar page it would not. :confused:
     

Share This Page