Stop programs from loading on startup

Discussion in 'Mac Basics and Help' started by SimonMW, Jul 25, 2008.

  1. macrumors 6502

    Joined:
    Jan 15, 2008
    #1
    I posted about this once before but never found a satisfactory solution.

    I have a Mac Pro tower and my father has a Macbook. Both machines have the latest version of Leopard.

    My dad is pretty elderly and despite having worked with computers for a good deal of his life they now confuse the heck out of him.

    The problem is that every time I go to do a bit of maintenance on his Macbook I always find that somehow he has loads of programs listed in his login items! So each time he boots up the computer applications such as Mail, Firefox, Safari etc all load up automatically.

    He tells me he has never gone anywhere near the settings to add programs to the startup list, and in any case he doesn't have admin privileges so he is limited in the changes he can make to the system.

    I cannot understand how these programs are getting listed as login items like that. At first I thought he was leaving programs open when he shut the computer down. But I have done that before with my Mac Pro and have never had programs loading automatically when I boot up.

    So what gives? Is there some kind of hidden setting somewhere that I can stop this from happening on the Macbook? Why is it happening all the time on his machine and not mine?
     
  2. macrumors P6

    Tallest Skil

    Joined:
    Aug 13, 2006
    Location:
    1 Geostationary Tower Plaza
    #2
    System Preferences, Accounts, the account in question, Login Items, delete what you don't want.

    I don't know why it would persist otherwise.
     
  3. thread starter macrumors 6502

    Joined:
    Jan 15, 2008
    #3
    Yeah, I know I can delete them, but this doesn't solve the problem because I'll go back a few days later and find that they have reappeared again!
     
  4. macrumors 68000

    HiFiGuy528

    Joined:
    Jul 24, 2008
    #4
    Give him a guest account.

    I have a problem with my guest account.
    - Finder opens at start-up. There is no start-up list to remove it in Guest account. Your thoughts?
     
  5. macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #5
    He can Right click on the app in dock and add to startup items. Probably what happened.
     

Share This Page