Stop Spotlight Indexing

Discussion in 'OS X' started by ichigo2006, Jan 17, 2008.

  1. macrumors newbie

    Mar 26, 2007
    Is there a way to stop Spotlight indexing everytime I restart?

    I use Bootcamp so I'm constantly swapping from Leopard to Windows and when I get into leopard, Spotlight indexes and the computer is slow until it finishes.

    Any ideas?
  2. Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    It shouldn't need to index after a restart. Have you left it alone so it completely indexes your drive or do you keep interrupting it?
  3. macrumors member

    Nov 24, 2007
    I have the same problem on Leopard/Bootcamp. Everytime I restart into OS X, it indexes and slows down for half minute...
  4. macrumors 68020


    Feb 3, 2004
    Virginia Beach, VA
    I've just noticed this same problem with external drives. I don't remember it happening before. I can let spotlight index and finish, eject the drive, plug it right back in and it goes through the whole indexing process all over again. This is really ridiculous.

    I've searched around some and don't see any solutions. On the apple discussion forums, there's a solution for permanently turning off spotlight on an external volume. See here:

    ... but I don't really want to turn it off, sometimes I want to search my external drives! Anyone got any other help on this one?
  5. macrumors regular

    Dec 15, 2007
    Got fed up of mine doing that, so I disabled spotlight.
  6. macrumors newbie

    Mar 12, 2010
    found this solution:

    Prevent Spotlight Indexing

    Sometimes you don't want your Spotlight to index some parts of your Mac, e.g. your backup drive. If that's the case, you can set up your Spotlight to prevent searching in several locations. This setting can be performed under System Preferences ▸ Spotlight ▸ Privacy. Adding that particular folder into the pane provided will result in Spotlight stop indexing that folder.
  7. macrumors 65816


    Jan 29, 2009
    Stillwater, OK
  8. macrumors newbie

    May 6, 2012

Share This Page