Straight Talk Iphone 4 Unable to send MMS to other imessage devices.

Discussion in 'iPhone Tips, Help and Troubleshooting' started by goblin cadet, Aug 7, 2012.

  1. macrumors newbie

    Joined:
    Aug 7, 2012
    #1
    Ive been having problems with MMS on my iphone. I am able to receive pictures from anyone. I am able to send pictures to anyone who does not use an imessage. However sending a picture to someone who is using imessage will not work. The picture will appear to go through as delivered, but they will not receive it. I am using Straight Talk and my settings are:

    Cellular Data
    APN: att.mvno
    Username:
    Password:
    MMS
    APN: att.mvno
    Username:
    Password:
    MMSC: http://mmsc.cingular.com
    MMS Proxy: 66.209.11.33:80
    MMS Max Size: 1048576
    MMS UA Prof URL:

    Thanks for any help in advance
     
  2. thread starter macrumors newbie

    Joined:
    Aug 7, 2012
  3. macrumors 68030

    aziatiklover

    Joined:
    Jul 12, 2011
    Location:
    8.8.8.8 and 8.8.4.4
    #3
    Go into their website and install the carrier data package!
     
  4. thread starter macrumors newbie

    Joined:
    Aug 7, 2012
    #4
  5. macrumors newbie

    Joined:
    Sep 13, 2010
    #5
    mms not working

    Anyone have any clues on how we resolve this. because i even checked the settings on my 4s and still no joy on my sons 4
     
  6. macrumors newbie

    Joined:
    Jun 2, 2010
    #6
    I followed the directions here: http://wiki.howardforums.com/index.php/Straight_Talk_iPhone

    It requires installing some software and changing the backup file. I would recommend backing up the phone to the computer twice so you have two backup files. On my 2nd phone, the backup became corrupted, so I had to do a restore and install from a slightly older backup.
     
  7. macrumors newbie

    Joined:
    Sep 13, 2010
    #7
    Mms

    I had done all that before with the exception of resetting network settings. I reset network settings and just used tetherme which i already had installed and it worked perfectly.

    I suspect that as the unlockit site had the settings correct as well, either jailbroken/unjailbroken solution will work fine. The key seems to be to reset network settings, at least for what ever reason that worked for me.

    Thanks for the post.
     
  8. macrumors 65816

    Gemütlichkeit

    Joined:
    Nov 17, 2010
    #8
    I've been having some serious iMessage problems this week. I've done everything from changing the APN, resetting, restoring, editing files with iBackupBot, changed date/time settings… everything.

    It appears it's something on Apples end.
     
  9. macrumors member

    Joined:
    Jul 26, 2012
    #9
    I had this issue with my 4. Just got the 4s, and this issue doesnt really seem to exist, sim swap is super easy.But I just reset my apple id pw, and then my pics stopped working. So had to redo the sim swap apn again and it works fine. My guess is trying to activate the apple id at startup and then do the sim swap. If the apple id breaks it appears the mms do as well. We no longer have a need for a factory unlocked phone with straight talk, so I dont think that would matter either:
     

Share This Page