Strange battery capacity problems with MBP CD

Discussion in 'MacBook Pro' started by ToastMaster, Dec 12, 2006.

  1. ToastMaster macrumors regular

    ToastMaster

    Joined:
    Nov 10, 2005
    Location:
    Tacoma, WA
    #1
    Ok, this is a weird problem, and I haven't heard of this happening before...

    So I've had my Core Duo MBP for about 2 months now, and today my battery started acting pretty weird. I started using it plugged in, with battery fully charged so it was just running off of the outlet. The LED on the Magsafe remained green, and my battery capacity indicator in the top right hand corner said 100%.

    So I later unplugged it and started using it as normal. Problem is, disconnected from the adapter, the battery indicator still read 100% several minutes into my use, and even saying 100% when the laptop ran out of power and shut off. So I left it off for about 4-5 hours, then plugged it back in (thinking that maybe I just need to calibrate the battery)

    Now I have it turned on, and although I know that the battery HAS to be charging by now, the Magsafe LED remains green and the capacity indicator says 100%. What's going on?
     
  2. ToastMaster thread starter macrumors regular

    ToastMaster

    Joined:
    Nov 10, 2005
    Location:
    Tacoma, WA
    #3
    Nope. Didn't work. Light's still green. And when I tried to see if maybe it really was at 100% capacity, it shut down.

    So I guess that there's some serious problem here.

    I'm pretty sure it's still under warranty, so should I take it to the Apple store and see if they can solve the problem? (probably just a new battery)
     

Share This Page