strange cursor clicks

Discussion in 'General Mac Discussion' started by nature girl, Oct 16, 2004.

  1. nature girl macrumors newbie

    Sep 12, 2004
    I don't know if this happens to other people, but whenever i'm typing an email in Entourage or using Word, wherever the mouse cursor is, it would automatically click and make the typing cursor to wherever the arrow was and make me lose my position in my typing. Whenever that happens, i heard this sound from my computer like the sound that you'd hear when you're saving a document. This happens like, every minute or so. Is there a way to disable that?? It's getting really annoying, i can't finish my emails, i can't type without the cursor going off to another place.... :mad:
  2. Blue Velvet Moderator emeritus

    Jul 4, 2004
    Have you tried using a different mouse (or keyboard)?

    Does this also happen in other programs (e.g. TextEdit)?
    Or is it just Microsoft software?

    What version of Office is it?
    If it's Office 2004, have you downloaded the recent service-pack?

    What kind of Mac & OS do you have?
  3. nature girl thread starter macrumors newbie

    Sep 12, 2004
    it happens with everything. Even as i type this message. I have a powerbook g4, i bought it just over a month ago. it's not a mouse problem. it's a cursor problem... (i don't quite know how to explain it). It's the cursor arrow that's causing problems, so if i'm typing something, wherever the arrow may be (most of the time i have the arrow somewhere else in the screen that i'm typing), after a minute or so, i'd see my typing cursor move to wherever the arrow is. And this causes whatever that i'm typing to shift to another part of my text.
  4. PlaceofDis macrumors Core

    Jan 6, 2004
    so i take it since you have a powerbook that you are using the trackpad and keyboard on the 'book??

    if so, the problem is probably steming from you accidentally grazing or hitting the trackpad while typing, it used to happen to me all the time, and thats why when im at home i use an external keyboard and mouse

    if you are using an external mouse with the trackpad off when it is connected, im at a loss
  5. nature girl thread starter macrumors newbie

    Sep 12, 2004
    ok thanks.

    let me pay attention to my typing and see if that's the case.
  6. haiggy macrumors 65816

    Aug 20, 2003
    Ontario, Canada
    I tested out a laptop at an Apple Reseller near me. (Not a problem with my iBook) but under your peferences you probably have trackpad enabled for clicking if you tap it. Just go into the preferences and take it off.
  7. comictimes macrumors 6502a


    Jun 20, 2004
    Berkeley, California
    I do this a lot too. If you have a mouse, it's easiest just to have the computer turn off the trackpad while the mouse is attached.

Share This Page