Strange icon phenomenon.

Discussion in 'macOS' started by EGT, Oct 22, 2006.

  1. EGT macrumors 68000

    EGT

    Joined:
    Sep 4, 2003
    #1
    For the past few weeks my icons have been acting weird. (See attachments)

    They seem to go like this randomly but sometimes the icon is as it should be in the dock but not in the apps folder and vice versa. :confused: Today, most icons have changed but when it happened before it was only 10 - 15.

    When I noticed it just a few minutes ago, Finder locked up on me twice. Would that have anything to do with it? Disk utility shows SMART status as verified, no faults with the drive. Can't seem to find anything here or on the Apple support section.

    As I've been typing this, I had Finder lock up again and all of a sudden things are back to normal ... :confused: I think my Mac has a gremlin! :eek:

    Any ideas why this is happening?
     

    Attached Files:

  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    Okay, this is kinda what repairing permissions is actually for. Yes, you heard right. Repairing permissions (Disk Utility in the Utilities folder) could actually help here! Of course, also disable any theme changers and system hacks where applicable beforehand. :)
     
  3. EGT thread starter macrumors 68000

    EGT

    Joined:
    Sep 4, 2003
    #3
    I don't have any themes applied other than changing the default folder icons with Candybar (latest version) way back when I had a hard drive crash. That was 22nd December 2005.

    I repaired permissions and restarted there now but the Safari icon has changed again. :p Damn computer! :rolleyes:

    I should just remind you that the apps. all appear to work fine. No slow down or anything out of the norm in the activity monitor.

    I'm baffled. :confused:
     

    Attached Files:

  4. 2nyRiggz macrumors 603

    2nyRiggz

    Joined:
    Aug 20, 2005
    Location:
    Thank you Jah...I'm so Blessed
    #4
    Have you tried removing the icon from the dock and replacing it with a new one?

    Do you have any of these apps on external and not have the external hooked up(I'm sorry I had to ask:eek: )

    Have you tried repairing from your install CD?


    Bless
     
  5. EGT thread starter macrumors 68000

    EGT

    Joined:
    Sep 4, 2003
    #5
    Removing the icon and replacing it fixes the problem. Not sure if it stops it happening completely though.

    All my apps are installed on the Main drive in my Powerbook. Any external drives I use are for backups only, so no.

    Thanks for the help anyway guys. :)
     

Share This Page