Strange problem - user desktop folder is hidden

Discussion in 'Mac Basics and Help' started by slooksterPSV, Jul 3, 2006.

  1. slooksterPSV macrumors 68030

    slooksterPSV

    Joined:
    Apr 17, 2004
    Location:
    Nowheresville
    #1
    When I go to my home folder, there isn't an icon for Desktop, its actually hidden as if it were a .hidden or .DS_Store file. I've tried removing .hidden and .DS_Store, but that did nothing, why is it hidden from finder view?
     
  2. Queso macrumors G4

    Joined:
    Mar 4, 2006
    #2
    Are you talking about it being missing from the shortcuts on the left, or from the main finder window itself?
     
  3. yippy macrumors 68020

    yippy

    Joined:
    Mar 14, 2004
    Location:
    Chicago, IL
    #3
    I think he means it is hidden from his home folder, as in it doesn't show up next to his Documents folder like it should.

    Does it start with a dot in the name? I think there are programs to change the hidden status of folders but I don't know any off the top of my head. Try looking through versiontracker.com
     
  4. Queso macrumors G4

    Joined:
    Mar 4, 2006
    #4
    Thanks yippy. I think I've just recreated then fixed the problem on my PowerBook.

    slooksterPSV, open the Terminal program from your Utilites directory (Utilities is in the Go menu in Finder).

    Type the following:-

    ls -l <---that's a lower case L in both cases

    Does a folder named Desktop appear? On my PowerBook it listed it, but had the wrong permissions set to make it available in the Finder. Permissions were showing permissions drwx------ and it was missing in the Finder.

    To bring it back in Finder, I changed the permissions using the following Terminal command

    sudo chmod -R 755 Desktop

    Then from the Apple menu, I pulled up the Force Quit window and relaunched the Finder. The icon then re-appeared.
     
  5. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #5
    dynamicv is wrong; drwx------ (700) are the correct permissions for your Desktop--any stock Mac will have those permissions, and it's completely normal (it just means that nobody but you has access to it). Even if you didn't have read access, you could still see it in the Finder, otherwise other users' home folders would be invisible, which they're not.

    I'm assuming you can still put stuff on the Desktop? If so, then it must exist. (If not, it's just been deleted and you can safely re-create it--just make a new folder called "Desktop" and it will automatically be "blessed" as your Desktop folder, though I thought this folder was created automatically after a reboot anyway.) Try opening a terminal window and typing "ls -al" -- if it exists, this will show it, period.

    Assuming it exists, it's probably had it's "invisible" bit set--this is a MacOS (not Unix) flag that tells the Finder not to show the file (the original MacOS used it to hide files from the user, and it still works though .naming is now the "preferred" method).

    If this is the issue, there are share/freeware apps that can set this for you. Sorry, but I don't know what any of them are, but VersionTracker will find them for you.
     
  6. slooksterPSV thread starter macrumors 68030

    slooksterPSV

    Joined:
    Apr 17, 2004
    Location:
    Nowheresville
    #6
    I moved all the stuff to a temp folder and recreated my user then moved all the stuff back. So I got it fixed that way, I need to remember that though - the chmod one. See I think I messed it up when I was playing with symbolic links and all that with mkdir. So I think I messed it up there. Anyways, thanks for the help.
     

Share This Page