Strange scanner problem (needs direct usb connection)

Discussion in 'Mac Accessories' started by cool11, Feb 7, 2007.

  1. cool11 macrumors 65816

    Sep 3, 2006
    I purchased a new scanner to use with my new mbp. The canon lide 25, for simple tasks.

    I installed the driver and I discovered that the scanner operates properly only when it is connected almost directly to the macbook! Why this happens?

    I use to have a (no1) usb hub attached to my mbp and another one (no2) to attach all my peripherals. I would like to attach the no2 usb hub to the no1 usb hub in order to use the peripherals. Printer works ok with these connection.

    I had never had such problems in windows (usb hub connect to usb hub and then to a computer) and I cannot understand why the scanner wants such a specific(almost direct) connection to mbp.

    If I do not connect the scanner to no1 hub, then an error appears saying I cannot use the scanner etc.

    Is it normal? My room and equipment are in such a way that these hubs help me a lot.

    I hope you could tell me a solution.
  2. artesian macrumors newbie

    Mar 2, 2005
    Hi, I used to get this message when connecting usb devices that drew power from the connection - like your scanner - to my Mac keyboard. When plugged into the usb connection at the rear it was ok. I'm guessing that a possible solution would be to have a powered usb hub (assuming that your existing ones aren't).
  3. skybolt macrumors 6502a

    Feb 20, 2005
    Nashville, TN, USA
    This may or may not apply to your situation, but when I bought my first LiDE scanner, I could not get it to work using a hub. I discovered that my hub was USB1.0 and even though the scanner stated USB 1.0, it would not work. When I bought a newer hub -- a USB 2.0 (or whatever it was), the scanner worked perfectly. Could that be your problem?

Share This Page