Streaming video slower than a turtle after upgrading to Lion.

Discussion in 'Mac OS X Lion (10.7)' started by bob118, Jul 31, 2011.

  1. macrumors newbie

    Joined:
    Jun 20, 2010
    Location:
    Western Mass USA
    #1
    I installed Lion and I have noticed very slow streaming video feeds, are there any tweaks that are out there that can fix this. Or is this part of the downfalls of running Lion. I never had a problem before I installed Lion. I am running a iMac 27" 2.8GHz iCore5 with 4GB of memory and ATI Radeon HD 5750 1024 MB. any ideas or suggestions are welcomed.
    Thank You,
    Bob118
     
  2. macrumors 68030

    Joined:
    Jul 21, 2011
    Location:
    Los Angeles, CA
    #2
    Can you explain what you mean by streaming? Playing external video feeds off the internet? Off of a home network? Serving video is slow on the client? You are being way too vague to be helped.
     
  3. thread starter macrumors newbie

    Joined:
    Jun 20, 2010
    Location:
    Western Mass USA
    #3
    When I go to any web site that has video, it takes forever for it to buffer the video. Loads a little then plays it, stops then buffers a little more than plays and stops, it just doesn't buffer fast enough to keep up to the video, this would be for any video such as youtube, or help videos in photoshop help or video clips in usatoday.com in general all videos. Hope this helps as I don't really now how else to explain it
    Thanks
    Bob
     
  4. macrumors 68030

    Joined:
    Jul 21, 2011
    Location:
    Los Angeles, CA
    #4
    That has nothing to do with Lion.....I've had that issue with youtube for years! Its just a crappy video service. I have a 24Mb/s internet connection and I have to wait on youtube. Other sites that don't suck stream perfectly fine. If you are having trouble on other sites you might want to contact your cable company, as it may be a problem with your internet connection.
     
  5. macrumors 68030

    srf4real

    Joined:
    Jul 25, 2006
    Location:
    paradise beach FL
    #5
    Normally I'd say it's probably just poor bandwidth from the video server. Viewing media streams especially during peak traffic hours is very demanding on YouTube, etc, network servers and you are probably just stuck in a long line of people trying to access that media all at once.

    But you say this has occurred noticeably only since installing Lion. Your Apple specs wouldn't indicate that your machine can't handle a heavy load of hd streaming.. and Lion OS is working perfectly for me streaming iTunes hd podcasts on one display and youtube/ VGuide tv streams on the other.

    I think you are not alone though, search the forums you might find others are struggling with poor streaming downloads performance specifically on their iMacs. Hoping for a fix in the first update, 10.7.1 for you!:)
     
  6. macrumors 68020

    jayducharme

    Joined:
    Jun 22, 2006
    Location:
    The thick of it
    #6
    Remember that Lion needs a minimum of 2 gb RAM to function. So your allotted memory for many tasks is now effectively cut by 1/3 with only 4 gb available. Before I get Lion, I'm going to upgrade to 8 gb of RAM. This is getting ridiculous. I miss the days of 48 k disk drives ... for only $500.
     
  7. macrumors newbie

    Joined:
    Jul 31, 2011
    #7
    @bob118 is right - streaming video sucks on Lion (so far)

    Bob - I haven't found a fix yet, but I concur, websites that use streaming video (Comedy Central, even Netflix) behave totally different than they did before I upgraded to Lion. My system is similar to yours (27" iMac, 4GB Ram) and I cannot even use the same sites as before.
     
  8. macrumors 6502a

    TheGenerous

    Joined:
    Nov 14, 2010
    Location:
    I'm an Austronaut
    #8
    2006 MacBook, has always worked well.
    When I upgraded to 10.6.8 video became choppy.
    I did a Lion clean install, everything was erased and installed in a new partition. Now the sound coming from iTunes is choppy.
     
  9. mrichmon, Aug 2, 2011
    Last edited: Aug 2, 2011

    macrumors 6502a

    Joined:
    Jun 17, 2003
    #9
    I had video streams freezing and/or compression artifacts that resulted in blocky videos. By turning off application snapshots the video artifacts and freezing appear to be fixed. The details are at http://www.smallersystems.com/blog/2011/08/problem-with-video-stream-playback-in-os-x-lion-10-7/

    To try this fix, open "System Preferences->General" and uncheck the “Restore windows when quitting and re-opening apps” option.
     
  10. macrumors newbie

    Joined:
    Aug 17, 2011
    #10
    Thank you!

    This issue was driving me crazy, and the fix worked like a charm. Thank you so much!!:)
     
  11. macrumors newbie

    Joined:
    Mar 9, 2013
    #11
    So I decided to not be a leech and share my fix (signed up here just to post this answer)...

    Not sure if this is still happening to anyone and maybe my problem was isolated but I fixed the issue on my machine and thought I'd share...

    I was having MAJOR lag issues with streaming video online on my machine. To the point that the videos were unwatchable because of the jittery, choppiness, and generally overall poor performance.

    After troubleshooting for an hour I found that MY problem was stemming from a google chrome issue. I am all fixed now and here is where I found the solution.

    https://productforums.google.com/for...me/zRDBYF_yLdE

    Make sure you restart Chrome once you've followed the instructions for the fix to take affect.

    Although I know some people have way larger issues then just a crummy flash setting on Chrome but I hope this helps someone...
     

Share This Page