Stubborn external HD won't mount. Any tips?

Discussion in 'Mac Accessories' started by KidHoliday, Nov 3, 2006.

  1. KidHoliday macrumors newbie

    Joined:
    May 8, 2005
    #1
    My 200 Gig LaCie firewire external is having some issues. First of all, I think the powersupply is failing because it doesn't turn on 90% of the time. The times I do get it to turn on, it won't mount on my powerbook. I've opened up disc utility and the HD is nowhere to be found. Anyone know how to get a stubborn external HD to mount?:confused:

    Thanks,
    J
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
  3. CanadaRAM macrumors G5

    CanadaRAM

    Joined:
    Oct 11, 2004
    Location:
    On the Left Coast - Victoria BC Canada
    #3
    The first rule if you find yourself in a hole is.... Stop Digging!

    Attempting to access a drive with a failing power supply is a recipe for data corruption should you actually ever get it going, briefly.

    LaCie should be able to provide a new power supply (it's an external brick, yes?) They have had historical issues with it.

    Or if it's out of warranty pull the drive out and put it in a MacAlly case for $50 - $60 and be done with it.

    (kudos again to the Crab for brevity and speed.)
     
  4. KidHoliday thread starter macrumors newbie

    Joined:
    May 8, 2005
    #4
    Thanks for the help

    Thanks for the help guys,

    I'm looking into getting a new case. I didn't know that was even possible with these external HD's. Thankfully, this morning the drive did turn on and mount, and I managed to copy my data. All my important files & pics are safe. This could have been a lot worse.

    Thanks again,
    -J
     

Share This Page