Stuck pixel on my 5g video

Discussion in 'iPod' started by aznspyder, Apr 14, 2006.

  1. macrumors member

    Joined:
    Oct 24, 2005
    Location:
    California and Bangkok
    #1
    I just noticed that my 5g video iPod has one stuck blue pixel near the center of the screen. At first, I started to freak since I've only had it for a few months and taken really good care of it. But then it disappears and goes back to normal. And then it goes blue again. Any ideas what's happening?
     
  2. macrumors regular

    Joined:
    Jul 27, 2005
    #2
    try rubbing the dead pixel in a circular motion. call Apple and complain that it's dead smack in the center.
     
  3. macrumors 68030

    BlizzardBomb

    Joined:
    Jun 15, 2005
    Location:
    England
    #3
    Tried a pixel unsticker? I can't remember where does it (use a search engine) but there's lots out in MP4 format.
     
  4. macrumors G3

    Counterfit

    Joined:
    Aug 20, 2003
    Location:
    sitting on your shoulder
    #4
    I don't think that would work too well on an iPod, due to the stiff acrylic/whatever over the screen. Since this is the first report I've heard of for a dead/stuck pixel on an iPod video, I have no idea what Apple's policy is on it. I guess you should call/go to a store and see what they say.
     
  5. thread starter macrumors member

    Joined:
    Oct 24, 2005
    Location:
    California and Bangkok
    #5
    I'll try to find a video file to flash the screen a few times. I heard that it works. Otherwise, I'll call Apple and see what they can do about this.

    It's strange because it comes and goes all the time. It usually happens when I use my iPod for more than half an hour. Maybe due to heat?
     

Share This Page