"stuck" sending mail

Discussion in 'iPhone Tips, Help and Troubleshooting' started by clayk, Oct 10, 2007.

  1. macrumors member

    Joined:
    Jun 13, 2007
    #1
    My iPhone seems to be stuck sending an email. The status at the bottom of the screen says "Sending 1 of 1". The progress bar is at the end but the message does not go away. The result is that I cannot send or receive any mail.

    I thought the logical thing to do was to delete the email, or at least see what it was, in the outbox, but there does not seem to be an outbox.

    Reset does not help and I am it happens on wifi and Edge.

    Anyone seen this or have a solution?

    Thanks.

    Clay
     
  2. macrumors 65816

    chr1s60

    Joined:
    Jul 24, 2007
    Location:
    California
    #2
    Have you connected it to your computer at all? This might get rid of it by making the phone sync. If you have done a reset and connected it to your computer and still nothing has worked I guess all that is left is to restore your phone.
     
  3. macrumors 6502a

    Joined:
    Sep 30, 2005
    Location:
    Green Bay, WI
    #3
    East fix. Well, it should be... Go into mail and then hold the home button down until the springboard appears. You have force-quit Mail and its services. Open mail back up and it should resend it or uf it did actually go out, send nothing.
     
  4. macrumors 65816

    Joined:
    Sep 13, 2002
    Location:
    Surrey, UK
    #4
    I've had this a LOT on my iPhone, in fact this last week it's been practically every time I've tried to send mail, both over wifi and Edge/GPRS.

    Curiously, while it's sending, making a phone call makes it send straight away as soon as the call connects (I get the swoosh sent mail sound).

    Tried force quitting, resetting etc., and it's still the same.

    Can anyone suggest anything?
     
  5. macrumors newbie

    Joined:
    Aug 7, 2007
    #5
    I am having the same issues starting today with sending a message!
     
  6. macrumors 601

    Joined:
    Nov 12, 2007
    #6

    Same here, I never had this issue for the last two months, and now it just appeared as an issue today.

    Resetting, full restore, forcequit does not work for me.
     
  7. macrumors 601

    Joined:
    Nov 12, 2007
    #7

    Fixed the problem, I had two email accounts. The outbox appeared in the first mailbox (even if i was sending the email from second mailbox) and I think Mail got confused on which smtp server to send it thru and thus the stuck email came up. I was able to go into the outbox to delete it.
     
  8. macrumors regular

    Joined:
    Mar 21, 2002
    #8
    iTouch also had this problem...

    I have an iTouch and just had this problem too..

    Thanks for the fix, holding the home button reset it and its fine for now..

    Chris
     
  9. macrumors newbie

    Joined:
    Jan 20, 2008
    #9
    email problems

    just recently got an iphone , unlocked to work in canada. I can't access email won't send or receive. put in configurations , still nothing . can anybody help? G
     
  10. macrumors newbie

    Joined:
    Aug 18, 2009
    #10
    I had the same problem where my email was stuck and there was no Outbox.

    One way I found to get out of it. I turned on airplane mode. Sent a new email. Now I can see my outbox; Then I deleted both of the emails from the outbox, and turned airplane mode off.
     
  11. macrumors 6502a

    Joined:
    Jul 20, 2007
    #11
    Since OS 3.0 came out, I can no longer cause Mail to force quit by holding the home button. In fact, it doesn't look like I can get any app to force quit in that manner.

    Anyone else? Maybe I need to restore the device... :confused:

    Edit: I just went to the Apple discussion forum, where I found a post that says that with the introduction of OS 3.0, the method to force quit an application has changed, Hold down the sleep button until the red slider appears. Release the sleep button and then hold down the home button. This works to force quit, for me at least. Is this news only to me? Everyone else knew about the change?? It turns out that this is on page 46 of the latest version of the manual. Apple doesn't do much to help those of us who update our firmware. They could have included this in a release notes document.
     
  12. Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #12
    This happens quite a lot with my wife's 3G phone since it got upgraded to 3.0.

    It never happens to mine (3GS) aside from the different model types, she does have a lot of email accounts defined and hardly syncs her phone with the computer.

    Forcing quitting seems to handle it, but I'll see if syncing the phone on a regular basis resolves it as well.
     
  13. macrumors member

    Joined:
    May 7, 2007
    #13
    I have had the same issue and have just ignored it until I saw this post. I put my phone in airplane mode. Created an email and sent it. Made sure it was in the outbox and turned airplane mode off. The email sent and the "1 unsent email message" has disappeared from the bottom of the mail screen.

    Like I said, it was an annoyance, but I am now glad it is gone.

    Thanks guys!
     
  14. macrumors newbie

    Joined:
    Jan 23, 2010
    #14
    Turn off wifi, use 3g and one mail account.

    Was just having the same problem sending a three word email reply. Stuck sending. I have a wifi and 3g connection and 3 email accounts. I tried solutions posted here with no luck. Looked in iphone manual of all places and found a possible solution. It suggested turning off wifi under settings, in order to use 3g only. Did so and email went. I tried another test email and it went instantly. But, at that time I had only one email account turned on. I turned on another account to receive the test email and turned wifi back on and tried another test. Locked up again. Had to turn off phone, turn off wifi, turn off all but one email account and leave only in 3g. Tried another test. Went instantly. Turned 3g off and wifi on. Tried another test. Locked up.
    Turned wifi off and 3g on. As soon as I went into mail the test message sent.

    Solution in my case for lock up in sending mode seems to be: Have only one email account on and use 3g. :rolleyes:
     
  15. macrumors newbie

    Joined:
    Feb 27, 2010
    #15
    1-Turn off the phone by pressing the on/off bottom for 3-5 sec
    2- Slide the to power off -the phone will be off now
    3-Turn the phone on, by pressing the on/off bottom again
    The problem solved
     
  16. macrumors newbie

    Joined:
    Apr 19, 2010
    #16
    stuck on send

    Hello Unity, when you enter mail application and hold the home button the voice recognition application starts.....what springboard are you refering too? I also have the problem and our company is using exchange to sink with phones. Since dowloading the new Itunes application my Iphone will not sink either. Working with apple to fix the last days. please explain further if you would be so kind.
     
  17. macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #17
    Problem is they're only in England.
     
  18. macrumors newbie

    Joined:
    Mar 7, 2009
    #18
    Thank you so much for this post. I have had an email stuck sending for several days on my iPad imap account. Finally able to delete it!:)
     
  19. macrumors member

    Joined:
    Nov 30, 2006
    #19
    Me too, this is what worked for me. Thanks for the Airplane mode fix.
     
  20. macrumors newbie

    Hummy

    Joined:
    Aug 30, 2010
    Location:
    London, United Kingdom
    #20
    I've been using Google Sync (Microsoft Exchange Server) and recently added a regular Google IMAP account to sync my notes between my phone and email but this account seems to have been the culprit as soon as I deleted it, the messages in my Outbox made their way to wherever they needed to be.
     
  21. macrumors newbie

    Joined:
    Apr 29, 2003
    Location:
    Albuquerque, NM
    #21
    Imap

    This bug can be triggered by accounts marked as inactive. Try deleting the account and see what happens.

    I found this out because I had an old GMail IMAP account on my iPhone that was set to an inactive state, and had the same stuck outbox problems. After deleting that inactive account all my stuck emails were sent immediately.
     
  22. macrumors newbie

    Joined:
    Oct 27, 2010
    #22
    3G outbound message with invalid e-address

    Won't send important message due to invalid e-address, but won't identify which is problem and won't send to those with valid addresses. Very frustrating! Any brilliant suggestions?
     
  23. macrumors newbie

    Joined:
    Aug 14, 2008
    #23
    Thanks, same exact problem. (GMail IMAP inactive, primary GMail Exchange active) I deleted the unused IMAP account and now my mail sends every time.

    It was so annoying thinking I sent someone an email only to discover it didnt send hours or days later. I'm back in action.
     
  24. macrumors 65816

    oplix

    Joined:
    Jun 29, 2008
    Location:
    New York, NY
    #24
    excellent post. Fixed the problem. Althought "created an email and sent it." part is not required.
     
  25. macrumors newbie

    Joined:
    Aug 14, 2015
    #25
    I know this thread is old and dead but perhaps someone else will run across this as I did while searching for a solution.

    I tried forwarding an email that had an attachment of 3MB from my iPhone 5C running iOS 8.4.1 the other day. It ended up freezing my mail and constantly trying to download the 3MB file. The problem started on Monday and went all the way thru Friday (today), in that time I was in and out of many wifi locations. Nothing seemed to fix my problem. I tried removing email accounts and was just steps away from purging my phone and starting all over again from scratch. Came across this page as a last ditch effort before clicking the button. Turning my phone to airplane mode then going into my mail app worked perfectly dzanter. It stopped trying to download the 3MB pdf file and let me cancel out. Thank you so much to everyone that posted to this thing years ago and not killing old threads.
     

Share This Page