Subler? How do you make file play subtitles by default?

Discussion in 'Apple TV and Home Theater' started by DaGrandMastah, May 12, 2013.

  1. macrumors 6502a

    Joined:
    Mar 19, 2011
    #1
    I can't figure out how to set that. I have a couple of foreign language films that aren't dubbed....how exactly do you go about setting it as default?

    I currently have the language track as 'alternate group 1' and subtitle track as "alternate group 2' with both selected in teh main screen. Is there something I'm missing?
     
  2. macrumors newbie

    Joined:
    May 13, 2013
    #2
    From my understanding you just tick the one you would like to be the default. If that doesn't work, iTunes (and everything you transfer/share it to from there) should just remember that you like having the subs turned on for that video after the first time you switch them on :)
     
  3. macrumors 68030

    Joined:
    Sep 21, 2011
    #3
    You tick one, leave the other(s) unticked, save file. Then when the movie is playing, you just choose which of the subtitle tracks you want to use.
     
  4. macrumors 601

    HobeSoundDarryl

    Joined:
    Feb 8, 2004
    Location:
    Hobe Sound, FL (20 miles north of Palm Beach)
    #4
  5. thread starter macrumors 6502a

    Joined:
    Mar 19, 2011
    #5
    Thanks guys. The subtitles are all definitely working on all of the video but only when I select them. I just want to ensure that files that only have a foreign language track automatically play the subtitles when i play the movie. I'll try some of your suggestions.
     
  6. macrumors 6502a

    J@ffa

    Joined:
    Jul 21, 2002
    Location:
    Behind you!
    #6
    What you actually have to do is:

    1. open the file in Subler (make sure you're on the latest version as this is a relatively new feature)
    2. click on the subtitle track you want to be the default in the list
    3. the penultimate option in the list (beneath all the number fields) is 'Forced'. select the dropdown menu and change it from 'No' to 'All Samples Are Forced'
    4. then go to 'Forced track' at the bottom and select the ID number of the subtitle you've selected.

    Hit save and you're done! I could be wrong as I don't do it using the method mentioned previously, but enabling subtitles explicitly in the settings and choosing a language will usually turn them on for everything.
     

Share This Page