Subtitles are always on by default undesirably

Discussion in 'Apple TV and Home Theater' started by Tandaemonium, Apr 1, 2011.

  1. macrumors newbie

    Joined:
    Oct 30, 2008
    #1
    I'm in the process of ripping my DVD collection and adding them into my iTunes library to stream to my apple tv 2.

    The basic steps I'm doing:
    - I'm using the apple tv 2 preset in the latest Handbrake.
    - If there are any subtitles I add them one by one and none of them are checked off for "Default" intentionally.

    I do not want any subtitles to display by default (except of course any forced ones for foreign language scenes). Unfortunately, every video I rip will display the English (default) subtitle track, if available. I do have closed-captioning off on the ATV2.

    I've been trying to google the problem but cannot find or cannot seem to enter just the right query in a search. I thought maybe this was just an Apple TV 2 bug, but maybe it isn't?

    Additional info:
    I'm also adding any metadata via Subler. And within Subler, I do uncheck the subtitle track which appears to always be checked initially upon opening a freshly ripped-via-Handbrake video file. I figured that would do it but it doesn't.

    Not sure if it's something in Handbrake to do, some setting on the Apple TV2, setting in Subler, or even a setting in iTunes I'm missing.
     
  2. macrumors regular

    Joined:
    Sep 15, 2010
    #2
    In HB under the subtitles Tab you should have burn in and force only. That will only show subtitles if movie requires it. the key is checking forced. You select the track..

    that is if I am understanding what you are asking.
     
  3. thread starter macrumors newbie

    Joined:
    Oct 30, 2008
    #3
    So you're saying I choose "Foreign Audio Search" and check off both Forced Only and Burned In; then select English and check off Default here (or don't check off Default but just have English selected)?

    The desired result is once I start playing the movie on the ATV2, I do not want to see any subtitle showing up at all - I only want subtitles if and when I choose to have them on. Currently, I have had to hold down OK to turn off subtitles manually for every video I add.
     
  4. macrumors 6502

    Joined:
    Oct 18, 2005
    #4
    Do the subtitles you are talking about look like clean, rendered text and a black bar or large and yellow, like the subtitles you see on a DVD?
     
  5. thread starter macrumors newbie

    Joined:
    Oct 30, 2008
    #5
    They render fine. Translucent black bar with white text. The quality of the subtitles are great. No issue there. I usually find the matching srt files since i want soft subs.
     

Share This Page