SuperDrive buffer under-run?

Discussion in 'Macintosh Computers' started by macphoria, Apr 20, 2003.

  1. macphoria macrumors 6502a

    macphoria

    Joined:
    Nov 29, 2002
    #1
    My SuperDrive is unable to burn iDVD movie because of "buffer under-run" error comes up. Has anyone experienced this? Does anyone know what might be causing this?
     
  2. Catfish_Man macrumors 68030

    Catfish_Man

    Joined:
    Sep 13, 2001
    Location:
    Portland, OR
    #2
    Yeah, it used to be a fairly common error with burners. I know the combo drive on my MDD G4 supports buffer underrun protection (burning with toast anyway). Try burning at a slower speed.
     
  3. nanosound macrumors regular

    Joined:
    Dec 22, 2002
    #3
    Toast requires you to check a box for underrun protection.
     
  4. macphoria thread starter macrumors 6502a

    macphoria

    Joined:
    Nov 29, 2002
    #4
    I'm using iDVD 2.1 to burn a movie onto DVD-R. As far as I know, there is no way to adjust the burning speed. Or is there?
     
  5. acj macrumors 6502

    Joined:
    Feb 3, 2003
    #5
    are you multitasking?

    This happens because the computer can't provide data fast enough. A constant stream of data is required. If it is broken, the whole disc is wasted, unless there is some sort of buffer underrun protection which is common on most modern drives.

    So if you are doing other things while burning, try closing all other programs and give it a go without touching the computer.
     
  6. macphoria thread starter macrumors 6502a

    macphoria

    Joined:
    Nov 29, 2002
    #6
    acj,

    Yes matter of fact I was multi-tasking, surfing the web while it was burning. I thought it wouldn't matter since OS X handles multi-tasking pretty well. I'll do what you suggested and see how it goes. Thanks.
     
  7. HasanDaddy macrumors 6502a

    Joined:
    Jul 16, 2002
    Location:
    Los Angeles
    #7
    Macphoria - buffer underruns suck :(

    but try the following ----

    1. Close all other programs and DON'T TOUCH YOUR COMPUTER, as you plan to do

    2. avoid burning things off of a Firewire drive....only burn whats on your internal HD, as the FireWire can't keep up sometimees

    3. Make sure that you go to your energy settings and never allow your computer to sleep

    the worst thing in the world is waiting 2 hours for a DVD to burn, and then have it screw up because your comp goes to sleep!
     
  8. yzedf macrumors 65816

    yzedf

    Joined:
    Nov 1, 2002
    Location:
    Connecticut
    #8
    macphoria - ignore all the silly advise by the previous posters. what you need is more memory, and/or a faster hard drive. to me, stopping everything else that i am doing to burn a disk is unacceptable! this is not OS 9 anymore damnit. OS X can do this, but your hardware is lacking (sorry). as a minimum, you should have 512MB of RAM. you don't have folding or SETI or anything else running (web server or samba or anything also) do you? OS X can do many cool things, but it wants the memory to do it with. if your hard drive is 5400rpm, then i suggest 7200rpm as well.
     
  9. acj macrumors 6502

    Joined:
    Feb 3, 2003
    #9
    silly advice

    Well this is all part of troubleshooting. If my silly advice does not work, than perhaps it's a bad drive and upgrading everything else wouldn't help at all.

    For some people the simple (and cheep) solution is best. Me, I'd upgrade...
     
  10. Eckslusive macrumors 6502

    Joined:
    Dec 12, 2002
    #10
    I thought the macs never had that problem with the over/under run buffer during burning. Guess I was wrong.
     

Share This Page