System 7 on Powermac g4

Discussion in 'PowerPC Macs' started by 512k, Nov 7, 2010.

  1. macrumors newbie

    512k

    Joined:
    Nov 7, 2010
    Location:
    Cambridge, Massachusetts, USA
    #1
    First of all, i'm new to this forum, so i'm not sure if this is the right place to post.

    greetings , one and everyone. i need to know if it is possible to run system 7 on a powermac g4 running 10.4.11. i have a virtual startup disk (.img), but as you know, classic only supports os 9.1+. is there a way to maybe create a disk partition to run system 7 on? thanks,

    512k ftw.
     
  2. gr8tfly, Nov 7, 2010
    Last edited: Nov 7, 2010

    macrumors 603

    gr8tfly

    Joined:
    Oct 29, 2006
    Location:
    ~119W 34N
    #2
    Depending on which PMG4, 8.6 is the probably earliest it will boot to.

    Edit: misread as PB

    Edit: the earliest G3s could only run 8.0. You'd have to go back to the 601-604 series to run Sys 7.
     
  3. thread starter macrumors newbie

    512k

    Joined:
    Nov 7, 2010
    Location:
    Cambridge, Massachusetts, USA
    #3
    1. i am not using a powerbook g4, i am using a power MAC g4

    2.system 7 should run on ppc i just need to figure out how
     
  4. Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    Whakatane, New Zealand
    #4
    The earliest systems shipped with 8.6, so that's the earliest version that you'll get running natively (and as gr8tfly mentions, if your system is newer then you may only be able to run 9).

    There are emulators available (such as vMac) but I don't know how compatible they are.

    All NewWorld machines (this includes all G4s) lack the toolbox ROM required by System 7. It is not possible to run System 7 natively.
     
  5. thread starter macrumors newbie

    512k

    Joined:
    Nov 7, 2010
    Location:
    Cambridge, Massachusetts, USA
    #5
    i do have a copy of Mini vMac, is there any way i can run from that? an if so, where do i find the roms?
     
  6. macrumors 603

    GimmeSlack12

    Joined:
    Apr 29, 2005
    Location:
    San Francisco
    #6
    Actually I think the earliest PPC's shipped with 7.6 on them. The earliest were the 6100, 7100, and 8100's. System 8 was not released until the 2G PPC's came out and finally System 9 with the G3's.

    Thus, trying to get System 7 on a G4 is probably not possible.
     
  7. macrumors 603

    gr8tfly

    Joined:
    Oct 29, 2006
    Location:
    ~119W 34N
    #7
    See my edits above.
     
  8. macrumors Core

    Joined:
    Jun 16, 2004
    #8
    Yeah, I'm fairly sure my 7500/100 had 7.6 on it. In fact it did, as I got OS8 for christmas the following year.
     
  9. XaPHER, Nov 7, 2010
    Last edited: Nov 7, 2010

    macrumors member

    XaPHER

    Joined:
    Oct 13, 2010
    Location:
    In the Underworld
    #9
  10. Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    Whakatane, New Zealand
    #10
    I was referring to the earliest G4s as that's what the OP said he was trying to use.
     

Share This Page