Talking to a unix machine?

Discussion in 'Mac Basics and Help' started by Ogre55, Jul 14, 2005.

  1. Ogre55 macrumors member

    Joined:
    Apr 24, 2005
    #1
    I have an ibook running X.4 I have another machine running a different unix OS. I want to be able to transfer files between the machines. Both are recieving an IP from my liksys router so they are properly connected. It woudl be easiest if I could just see the other machine as a server in finder but I can't figure out how to get that going. So I tried to use FTP. Using that I can see all of the files on the other machine using the client on my ibook but any time I try to transfer files I get a message that a connection couldn't be formed. Any suggestions...anyone?????
     
  2. Linkjeniero macrumors 6502

    Joined:
    Jan 6, 2005
    #2
    If you are feeling too lazy to set up a network, you could just use SFTP (that's what I do :p). If you want to use the iBook as the server, just open the System preferences, Share, and check Remote Session. Then in the other Unix box you could use sftp (in the terminal) or some other sftp app to access it.
     
  3. Doctor Q Administrator

    Doctor Q

    Staff Member

    Joined:
    Sep 19, 2002
    Location:
    Los Angeles
    #3
    It may not matter, but what type of Unix is the other computer running?

    Do you get the error message when you FTP transfer TO the Unix system from the Mac or when you FTP transfer FROM the Unix system to the Mac?

    If you click Network in a Finder window, do you see your Unix system there? Do you see anything there?

    You might select menu choice Go -> Connect to Server... in the Finder and try a Server Adddress such as nfs://12.34.56.78 (the IP address of the Unix system) in case NFS (Network File System) is turned on on the Unix system and you can reach it that way.

    If you are interested in using the Unix system to access your iBook, you should start by checking the Sharing pane in System Preferences on the Mac to see which kind of sharing services you have (or want) enabled.

    I wonder if your router is blocking packets between your two computers. Do you know how it was set up, e.g., with NAT (Network Address Translation), DHCP (Dynamic Host Configuration Protocol), or any particular firewall settings?
     
  4. Cooknn macrumors 68020

    Cooknn

    Joined:
    Aug 23, 2003
    Location:
    Fort Myers, FL
    #4
    Samba

    I would install Samba on the UNIX box. Then your Mac could connect to it as if it were a shared drive.

    From Mac Help:
     
  5. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #5
    I'm assuming you're savvy on this point, if you're running Unix, but how is the firewall set on the Unix box?
     
  6. Ogre55 thread starter macrumors member

    Joined:
    Apr 24, 2005
    #6
    My router is using DHCP with no special settings enabled. I can't see the unix machine in network finder window. As far as ftp: I am working on the ibook and the client can't connect to either send or retrieve files even though I can see the files on the other machine.

    If I could set up a network I would do it but I am not sure what I would do.

    The operating system on the other machine is is EvoX if that helps.
     
  7. Ogre55 thread starter macrumors member

    Joined:
    Apr 24, 2005
    #7
    One of the real problems is it isn't a typical unix machine. EvoX is unix based but it isn't a normal computer.
     
  8. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #8
    Okay, yeah, so that would probably have helped from the start. :rolleyes:

    Does your xbox have a account username and password defined? This tutorial on networking XBOXes suggests that they do not accept anonymous FTP, and that their u/n and p/w, if I understood correctly, will both be "xbox" by default. Did you get prompted for this before you were able to see the xbox files from the iBook?

    What happens when you ftp from the terminal prompt on the Mac? What specific error messages do you get? Paste them from terminal to here.
     
  9. Westside guy macrumors 601

    Westside guy

    Joined:
    Oct 15, 2003
    Location:
    The soggy side of the Pacific NW
    #9
    Turn off passive mode (PASV) on your FTP session. Passive FTP roams all over the place port-wise, and it's likely that your firewall (at one end or the other) is interfering with it.

    Having said that - something like sftp is a much better alternative from a security standpoint. It also only requires port 22 to be open, which is another plus.

    As a tangential side note - I just discovered that Fedora Core 4 includes a Rendezvous/Bonjour beacon! You can turn it on and use the same machine_name.local addressing to get to the box that you would with a Mac (or a Windows box running Bonjour).
     
  10. Ogre55 thread starter macrumors member

    Joined:
    Apr 24, 2005
    #10
    I don't know how to ftp using the terminal but using OsXygen as a ftp client I was able to log on to my xbox using the xbox as pass and user if I set it in active mode. But when I try to transfer files, I new window pops up and says that it is trying to connect. But it seems like it already should have been connected since I can see all the files on the xbox.
     
  11. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #11
    I think you're the first person I've ever heard of who uses Unix and doesn't know how to use ftp from the terminal! Wow. :eek:

    Well, the reason I asked you to try it is because I have no idea why your ftp client doesn't want to do its work, but I do understand the error msgs from the unix ftp command in terminal.

    Here's how you do it:

    - Open a terminal session (Terminal is in your utilities folder).
    - Type in "ftp (the IP address of the XBox)" (don't include the parenthesis)
    - When prompted type in the user name and p/w
    - Type "ls" to see the contents, "cd" to move around, etc.
    - Type "binary" "i" to change to binary download mode
    - Find a file to try transferring, and type "get (filename)"

    Come back with the error message you get, if you get one.

    All commands followed by <enter>
     
  12. Ogre55 thread starter macrumors member

    Joined:
    Apr 24, 2005
    #12
    I know I am inept. Someone set it up for me but now I am trying to figure it out. Going thru terminal it says that it transfered ok but sayed no info was transfered

    ftp> get xbox.xtf
    local: xbox.xtf remote: xbox.xtf
    200 Port command ok.
    150 Sending \xbox.xtf
    0 0.00 KB/s
    226 Transfer finished successfully. Data connection closed.

    I also tried it using the drive name (c:xbox.xtf) and still got the same resposnse.
     
  13. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #13
    Does a local copy of the file, empty or not, show up in the current directory when you do this? After you type "exit" to get out of ftp, you can type "ls" to see if it's there (you're probably in your home directory at this point).

    It's okay, btw, everyone has to start out inept. I'm sorry if I was curt. I think I've been confused since you started out by calling it Unix. I think if you said you had an XBox, I would have made less assumptions. I assume people who use Unix know more about computers than I do. :D
     
  14. Westside guy macrumors 601

    Westside guy

    Joined:
    Oct 15, 2003
    Location:
    The soggy side of the Pacific NW
    #14
    Let me add one more thing to mkrishnan's command-line ftp tutorial. After logging in with your username and password, but before doing anything else (in other words make this step 4), type "passive". You should get a message back saying "passive mode off". Then do everything else he says. Don't type "passive" again or you'll toggle it back on.

    Maybe it won't make a difference but it's worth a try.

    The reason you can see the files even if passive mode is causing the problem is the initial connection is made over the standard ftp ports (20 and 21). But as part of passive file transfer, the server passes back a random port number that the client listens to to grab each file - and that port changes with each file in the list. If those ports are being blocked (even when 20 and 21 are open) then the file transfers will stall.
     
  15. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #15
    Ahhh, that's really interesting! :) So, ftp thinks it is receiving a file, because it is initiated on the standard port, but then since the passive transfer port is closed, it gets no contents, and thinks it received an empty file? Very interesting....
     
  16. Ogre55 thread starter macrumors member

    Joined:
    Apr 24, 2005
    #16
    After adding the passive line I was able to put a file on the other box. Hurrah for you guys. You were able to walk me thru a simple command. I appreciate all the help that you guys have done. Do you guys have any suggestions for how I can get a client to work now. Or should I just try and figure out my way through terminal?
     
  17. Doctor Q Administrator

    Doctor Q

    Staff Member

    Joined:
    Sep 19, 2002
    Location:
    Los Angeles
    #17
    I don't know OsXygen, but if you tell us the Preference setting choices, perhaps we can tell you how to set them.
     
  18. Westside guy macrumors 601

    Westside guy

    Joined:
    Oct 15, 2003
    Location:
    The soggy side of the Pacific NW
    #18
    Yeah, and it gets odd also because firewalls don't interfere one way but they do the other; so passive might work fine when you're trying to do certain things but not others...

    Only reason I know any of this is from banging my head against a wall multiple times in the past doing pretty much the same thing. I suppose that's one advantage to running Linux vs. OS X - you end up learning about all the internal crap... cuz you HAVE to in order to get any darn thing to work! :D But OS X is much easier on my head.
     
  19. Ogre55 thread starter macrumors member

    Joined:
    Apr 24, 2005
    #19
    Is there any good books for learning how to use the terminal?

    The setting in OsXygen is
    Generic
    -Endable Extended logs
    -Do not check if osXygen is default ftp helper
    -Use BBEdit for all file types
    Connection
    -Show dot files
    -transfer dot files
    -Don't transfer newer ASCII files with same size
    -Don't tranfer newer binary files with same size
    -force server to list all files (-la)
    File Types
    -Enter a list of case insensitive file extensions for ASCII transfers
    Firewall
    -No firewall (proxy)
    -outgoing connections only (PASV)
    -Use FTP proxy (user@host)
    -Use Proxy (login + user at host)
    -socks
     
  20. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #20
    Four up from the bottom, "Outgoing connections only (PASV)" is the setting that is causing you trouble, according to Westside Guy's line of reasoning, which seems to be right. Try changing this setting and see what happens.

    Also try searching here for ftp clients. This (OsXygen) is not the most common one, AFAIK, although I don't even have an FTP client, other than the ftp in terminal. I know Fetch is popular, but it isn't free.

    This site should get you started on the command line ftp, if you decide you want to play around with that more. There is also a related command sftp that does secure ftp, but I doubt you can do that with the xbox. :)
     

Share This Page