Terminal automatically launches seti@home

Discussion in 'Mac OS X 10.3 (Panther) Discussion' started by michaelwarren89, Apr 30, 2004.

  1. michaelwarren89 macrumors newbie

    Joined:
    Jan 22, 2004
    Location:
    Brisbane, Oz
    #1
    Hi everyone,
    I've just started having trouble with my terminal.app (I'm still learning all the ins and outs of terminal). Normally when I launch terminal i get a window with my login shell (~ login$) and a cursor, ready for me to type. Most of the time I have a single window open running the seti@home CL, which i launch usually from the actual executable. Now when i launch terminal on it's own (from the Utils folder), it automatically launches seti@home. Even making a new shell does not stop it, it just tries to launch the file again and stops, then logs out, because you obviously can't run two setiathome instances from the same directory. I haven't done a thing to change this except installing Quicktime 6.5.1, which I'm quite sure can't be the culprit. I've repaired permissions, I've done everything, and I can't stop it from launching seti@home.

    What I think may be the problem is somehow the command to launch seti@home has been added to the script that terminal uses when it launches? I'm not sure on the actual ins and outs of terminal but from my limited experience this is all I can think of.

    Also one other problem, seti@home always puts its .sah files in my user directory, never the directory that I launch it from. This has been the same since 10.1 (I know use 10.3), and it's beginning to frustrate me. Is this a limitation of the seti@home client or something else?

    Thanks in advance
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    Here's some advice: check your .profile, .bashrc, .bash_profile, and .bash_login files (all in your user directory, if they exist) for lines that would start SETI@Home. If you do find something that is causing SETI@Home to be launched when you start Terminal, those lines are most likely also causing SETI@Home to use your user directory to store its files. I haven't used SETI@Home (but I do use Folding@Home, and don't have this problem), so I'm not completely sure as to what's causing it. If those lines aren't the cause of SETI@Home abusing your user directory, I'd suspect a configuration issue is to blame. See if you can find how to reconfigure SETI@Home so it stores its files in a location you prefer.
     
  3. michaelwarren89 thread starter macrumors newbie

    Joined:
    Jan 22, 2004
    Location:
    Brisbane, Oz
    #3
    Nope, no such luck. Every one of those files you referred to simply had the one line in it:

    /Users/username/SETI/setiathome; exit

    referring to the original location of the application. Deleting the line using pico in every one of the files did nothing, as did deleting every one of those files using another user's command line (that worked). The files just reappeared with that one line as soon as i saved the file and reopened it.
    Talking to a friend online I found that the command ENV may have yeilded a clue as that also has the same reference. But we are both unsure how ENV actually works. This has got us both stumpted. :mad:

    seti@home also has no preference file. It stores its preferences in those several files in the home driectory and they have little in the way of describing startup cmmands or the like, just usernames and work unit progress.

    Thanks for the help
     
  4. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #4
    You want documentation of the env command? Look here. The link is to online UNIX man pages, which should be applicable to Mac OS X.
     
  5. michaelwarren89 thread starter macrumors newbie

    Joined:
    Jan 22, 2004
    Location:
    Brisbane, Oz
    #5
    I finally fixed it. All i had to do was go to com.apple.Terminal.plist in my user library, delete 'executionstring' which was referring to setiathome, and it now works! (I did it all by myself I might add!)

    Thanks for your help anyway, it was much appreciated :)
     

Share This Page