Terminal messed me up

Discussion in 'Mac Help/Tips' started by modyouup, Jun 9, 2003.

  1. modyouup macrumors member

    Joined:
    Jan 18, 2002
    #1
    So there I am skipping happy go lucky throught the gardens of Unix when suddenly I'm subject to sniper fire from a micro$oft assassin!

    Yeah so, here's my problem. I never had any real qualms with the Terminal it always worked nice and fine fer me till just a few minutes ago. I go click on the happy Terminal icon on my dock and voila! Something I never saw before arose:

    --------------------------------------------------

    Last login: Mon Jun 9 17:55:20 on ttyp1
    Welcome to Darwin!
    /usr/share/init/tcsh/rc: No such file or directory.
    >

    --------------------------------------------------

    Ahhhh!! Where's my nice little user account and % sign? And what's this usr/blah/blah/poo? This happened out of nowhere and I don't get it. The little arrow is the prompt which works normally but I'm sure it's not supposed to be like that.

    Someone please help me with this! I'm running out of trees to hide in and the sniper is gaining on me. :(
     
  2. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #2
    While I can't offer you a solution, I took a little look around and found that I don't have a file called /usr/share/init/tcsh/rc, but i don't get an error. It seems like maybe it's trying to open that file when it shouldn't be.
     
  3. kylos macrumors 6502a

    kylos

    Joined:
    Nov 8, 2002
    Location:
    MI
    #3
    I'm looking into it right now, but the impression I get from the error is that your shell (tcsh) failed to load. Which is consistent with the fact that you can't do anything. (The shell is the program that allows you to access all your files and unix commands, roughly a command-line finder)
     
  4. f-matic macrumors member

    Joined:
    Jan 6, 2003
    Location:
    brooklyn
    #4
    hmmm...

    i've only used OS X briefly, but i think (please correct me if i'm wrong) the file it should be looking for is tcsh.rc - the resource file for the shell. try doing a 'ls -a' from your '/usr/share/init' directory to see if there's a file named tcsh.rc in there. my guess is that one of your shell startup scripts is a little messed up and specified the file tcsh/rc rather than tcsh.rc, so the shell is looking for a file in the folder 'tcsh' (which ma or may not exist) rather than the correct .rc file.

    that's the best guess i can come up with without access to an OS X machine! hope it helps..

    best,
    nick
     
  5. kylos macrumors 6502a

    kylos

    Joined:
    Nov 8, 2002
    Location:
    MI
    #5
    That's pretty good! I'm checking right now to see where the problem is at for sure.

    Since your terminal is not working open the find pane in the finder, set visibility to off and search your home folder. It will give you a long list. Open .login and tell us what it says.
     
  6. FattyMembrane macrumors 6502a

    FattyMembrane

    Joined:
    Apr 14, 2002
    Location:
    bat country
    #6
    if all else fails, you can just set the terminal to use a different shell in the preferences (i would suggest /bin/zsh-4.0.4 or /bin/bash)
     
  7. kylos macrumors 6502a

    kylos

    Joined:
    Nov 8, 2002
    Location:
    MI
    #7
    Do as fatty says. It will make it much easier to figure out the problem.
     
  8. f-matic macrumors member

    Joined:
    Jan 6, 2003
    Location:
    brooklyn
    #8
    one more possibility

    somebody had a similar problem over here:

    http://forums.osxfaq.com/viewtopic.php?t=3163

    did you install fink anytime recently? maybe worth taking a look at ~/.cshrc or ~/.tcshrc or ~/.login files. (i would make a backup of them before you start fooling around with anything though)...

    hope that helps,

    nick
     
  9. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #9
    Open Terminal Preferences and see what they're set to. Mine's set to "Execute the default logic shell using /usr/bin/login", but if I change it to "Execute this command: /bin/tcsh" it still works (but doesn't display the welcome message).

    I've attached my /usr/bin/login in case it's any help, I had to rename it to login.zip for the forum to allow me to attach it - make sure you remove the extension once you've downloaded it. And back up your old one first!
     

    Attached Files:

Share This Page