Terminal question: "You have mail."

Discussion in 'macOS' started by thomasp, Sep 2, 2006.

  1. thomasp macrumors 6502a

    Joined:
    Sep 18, 2004
    Location:
    UK
    #1
    I'm running OSX 10.4.5.

    I launched Terminal today to see what my uptime was and saw this strange new line beneath the "Welcome to Darwin!" line (3rd line in window):


    I've got Apple Mail open, and I don't have any new mail in there, so what is this thing that's now appearing in Terminal, and how do I "read" the mail and then get rid of the message?


    Thanks for the help :)
     
  2. Mitthrawnuruodo Moderator emeritus

    Mitthrawnuruodo

    Joined:
    Mar 10, 2004
    Location:
    Bergen, Norway
  3. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #3
    You'll be able to read it if you type mail like Mitthrawnuruodo suggested. This is a system level mail that's used for alerting users to things. I forget now but there are a couple of activities that you can do that will generate a mail message for the admin. It might be something related to system housekeeping. I thought it was sudo'ing from a non admin account, but that apparently isn't one if them.
     
  4. thomasp thread starter macrumors 6502a

    Joined:
    Sep 18, 2004
    Location:
    UK
    #4
    Hmmm, they seem to be some random network messages. Anyone any clue what they mean?


    Is it perfectly safe to delete these messages?
     
  5. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #5
    Those messages are being sent by ClamXAV or some other implementation of Clam antivirus, right? Yes, basically. Delete them after you read them. They just mean what they say. As long as it's not consistently failing to get virus definition updates, you should be fine.
     
  6. thomasp thread starter macrumors 6502a

    Joined:
    Sep 18, 2004
    Location:
    UK
    #6
    Yep, I'm running ClamXav. And I think those errors were caused when I forgot to turn off the proxy server settings when I came back from uni.


    Cheers for the help :)
     
  7. porg macrumors member

    Joined:
    Dec 3, 2008
    #7
    Instructions on how to solve the issue

    Synopsis

    As Mitthrawnuruodo and mkrishnan already said, it is a system level email.
    I also had this issue, and found out where to check for for it.
    You can use the following guide.

    Good luck!

    porg

    Instructions for Terminal.app (aka the command line shell)

    Go to the directory (=folder) where the system level email files for all users are stored, and list them:

    cd /private/var/mail/; ls -l

    Display the email(s) for the user which you fill into <username>.
    Either use your username (without the angle brackets) or use the character * (asterisk) if you want all emails from users listed:

    cat <username> | less

    Finally erase your mail file, in case you do not need it anymore.

    sudo rm /private/var/mail/<username>
     
  8. tomasio macrumors newbie

    tomasio

    Joined:
    Feb 21, 2008
    Location:
    Vienna, Austria, Europe

Share This Page