Textmate adding symbols to txt/rtf file

Discussion in 'Mac Programming' started by drewyboy, Feb 20, 2013.

  1. macrumors 6502a

    Jan 27, 2005
    Hey everyone, I know some may have moved on from Textmate, but I'm using the textmate 2 alpha/beta whatever it is and I still like it. Anyways, I went to open a text file and some selection came up and I pressed enter... my mistake. Now when I open a txt or rtf file in text mate, it ads all the coding w/ it to.. here's a snippet:

    \f0\b\fs28 \cf0 Description
    \fs24 \
    \b0 This sample shows how to make the most basic of VoIP applications for making an outgoing call or receiving an incoming call.  You'll need a PHP server for serving up the Capability Tokens and responding to requests from Twilio when calls are received.  \
    You'll need to create a Twilio Application in your account, put 
    \b Server/auth.php 
    \b0 and 
    \b Server/basic-call.php
    \b0  up on a PHP-capable server, and then point the Twilio Application at 
    \b basic-call.php
    \b0 's public URL.\
    Any idea how to fix it and have it open as normal? I don't know where to look for the setting of who it's interpreting it.
  2. Guiyon, Feb 20, 2013
    Last edited: Feb 20, 2013

    macrumors 6502a

    Mar 19, 2008
    North Shore, MA
    That looks perfectly normal if you are opening an RTF file; those are RTF control codes. Are you getting this behavior with all files you open or just a couple of them?

Share This Page