1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

The disk you inserted was not readable by this computer.

Discussion in 'iPod' started by keeweepoo, Dec 26, 2007.

  1. macrumors newbie

    #1
    I have an ipod classic and work out of Mac OS 10. I bought it on e-bay and although it ipod has frozen twice in the last five months, turning it off then on has solved the problem. Then last week I was on a plane and it started going through each song in the playlist that I selected -- just showing the names and not playing anything -- until it went through the whole playlist and then went back to the menu screen like nothing had happened. Trying to fix it, I reset the ipod by toggling the hold switch and holding down the select and menu button until the apple icon showed up. Then a screen showed for me to select the language, I selected English, and it went to the normal menu screen and all my music was gone. When I tried to hook it up to my computer to re-load my songs, an error message kept coming up on my computer with a big exclamation mark that says
    Disk Insertion
    The disk you inserted was not readable by this computer.
    Initialize Ignore Eject

    Initializing takes me to a dead end. The ipod itself says "do not disconnect" while it's connected, so I know it knows it's connected, and when it is ejected and unplugged from the computer, the ipod makes me select the language again (every time I do it). I've read that some restored their ipod and then everything was fine, but I can't because my computer isn't recognizing my ipod at all. The ipod never shows any error messages and works fine... I just can't get my music on to it! I've tried other USB ports, other computers and get the same results. Resetting my ipod again also did nothing. I tried shutting down the computer and turning the ipod off and back on, nada. My ipod is charged. What can I do??? :confused: Please help :)
     
  2. macrumors newbie

    #2
    ipod not readable on this computer

    Hi,

    I'm having the same problem, "going through each song in the playlist that I selected -- just showing the names and not playing anything -- until it went through the whole playlist and then went back to the menu screen like nothing had happened."

    Did you find a fix? If so please post here.

    Thanks!
     

Share This Page