The *ORIGINAL* Unreal Tournament NOT working via Boot Camp!

Discussion in 'Games' started by Jeff Hall, Apr 10, 2006.

  1. Jeff Hall macrumors regular

    Jeff Hall

    Joined:
    Apr 10, 2006
    #1
    I loaded the original (circa 1998) Unreal Tournament onto XP (dual boot setup on my MacBook Pro).

    The graphics are choppy, and the game is unplayable because of this.

    Has anyone had any luck getting this classic to work? I tried the Direct3d, OpenGL, and Software Rendering options, but none work properly.

    The game looks great in 1440x900 though!

    I *really* want to play this game again!
     
  2. DougTheImpaler macrumors 6502a

    Joined:
    Feb 28, 2006
    Location:
    Central Illinois
    #2
    Have you updated to version 4.36 and then downloaded the optional OpenGL file for the game? Direct3D with UT is pretty choppy compared to OpenGL or GLide.
     
  3. Dagless macrumors Core

    Dagless

    Joined:
    Jan 18, 2005
    Location:
    Fighting to stay in the EU
    #3
    I can offer no help, but can agree that it looks beautiful on my 1680*1050 monitor too. Amazing how this and HL2 run in full specs and flies, yet Max Payne, Farcry and a few other games just refuse to run smooth at all.
     
  4. Jeff Hall thread starter macrumors regular

    Jeff Hall

    Joined:
    Apr 10, 2006
    #4
    I did download the v436 patch, but did not know about the optional OpenGL file for the game. I'll go look for it (would appreciate a link if anyone's got it handy!)

    Thanks for the suggestion!
     
  5. Jeff Hall thread starter macrumors regular

    Jeff Hall

    Joined:
    Apr 10, 2006
    #6
  6. crachoar macrumors 6502a

    Joined:
    Mar 22, 2004
    Location:
    Ohio
    #7
    The Chris OGL renderer pwns everything. You shall never have a problem with UT again. Enjoy.
     
  7. LagunaSol macrumors 601

    LagunaSol

    Joined:
    Apr 3, 2003
    #8
    Hope you've tried (or will try) UT2004. Onslaught is fantastic. Best Unreal game ever. Except for the original Unreal, of course, which rocked my world harder than any game before it (or since).

    Can't wait for UT2007. Wish they'd make vote-kick a default setting. Too many jackarses ruin too many games.
     
  8. Dagless macrumors Core

    Dagless

    Joined:
    Jan 18, 2005
    Location:
    Fighting to stay in the EU
    #9
    UT99 is still my fave. But 2007 sounds very good with its MMOFPS mode. Forget what Epic called it, but basically it's like a giant warzone. Pity I'm no fan of the weapons in UT games since being spoilt by HL2.
     
  9. socamx macrumors 6502

    Joined:
    Oct 7, 2004
    #10
    Unreal Tournament from 1999 hands down is the best UT game ever. UT2004 isn't bad, but it is nothing compared to UT in my eyes.

    If I ever got an Intel Mac, I'd install Gentoo Linux and Fluxbox just to run UT. UT in Linux is much better than UT in Windows. Window's mouse control is horrible...
     
  10. Schmittroth macrumors regular

    Schmittroth

    Joined:
    Dec 6, 2003
    Location:
    NYC, Astoria-Queens
    #11
    The original Mac UT99 used Glide 3D, OSX and none of the newer video cards support this. Does Windows UT99 use Glide too, and is the Open GL a patch? Has anyone run UT2004 on Boot Camp yet? How's the performance and anyone tried the Unreal Editor, finally on a Mac! (kinda).
     
  11. DougTheImpaler macrumors 6502a

    Joined:
    Feb 28, 2006
    Location:
    Central Illinois
    #12
    I haven't played UT'99 in FOREVER, though it IS my favorite of the series.

    Slightly OT: how does the OS X PR3 of UT run on G5-based systems, like a rev. B (Radeon 9600) iMac?
     
  12. Jeff Hall thread starter macrumors regular

    Jeff Hall

    Joined:
    Apr 10, 2006
    #13
    OpenGL drive results

    Alright, I finally got a chance last night to put the newest beta version of the Open GL drive for UT99 on my MacBook under Windows XP. The good news is, the game is now playable. But, I suspect there is tweaking that still needs to be done with the OpenGL driver settings, and I'm at a loss as to what I should put in the UnrealTournament.ini file.

    The game's graphics are no longer choppy, but I have the following problems:

    1. The game speed seems to be somewhat sluggish (1440x900). I'll try reducing down to 1024x768 next time.

    2. My Kingston optical mouse has "drift". That is, when I let go of it, the view continues to slowing change, usually drifting to the upper right, or whatever direction I was turning my viewpoint to last.

    I did not modify my stock .ini file after installing the OpenGL driver. Any recommendations?
     
  13. Jeff Hall thread starter macrumors regular

    Jeff Hall

    Joined:
    Apr 10, 2006
    #14
    Problem Solved!

    Great news! I got UT running PERFECT under XP on my Macbook! Here's the magic trick:

    1. Launch Unreal Tournament using the following command line:

    C:\UnrealTournament\System\UnrealTournament.exe -cpuspeed 2160

    2. Minimize the window

    3. Open Task Manager->Processes

    4. Select UnrealTournament.exe and right-click->Set Affinity...

    5. Uncheck the CPU 1 checkbox

    6. Restore/Maximize your Unreal Tournament window.

    7. Frag away!

    Substitute "2160" with the MHz for your Mac (e.g. 1830, 2000, 1670, or whatever).

    Now my question is, should I say with the v436 patch, or does the client need to be upgraded to the v451 patch?
     
  14. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #15
    Far Cry 1.33 runs perfectly under High settings on my iMac, however it crashes under Very High. It's weird.
     
  15. eXan macrumors 601

    eXan

    Joined:
    Jan 10, 2005
    Location:
    Russia
    #16
    I have rev. B iMac and OSX Preview 3 runs great! on 1024x768 MAX, the game averages at 100+ fps, sometimes drops to 50s-70s :)

    The lack of music is dissappointing though :(
     
  16. Schmittroth macrumors regular

    Schmittroth

    Joined:
    Dec 6, 2003
    Location:
    NYC, Astoria-Queens
    #17
    I'd upgrade so that you would be compatible with other peoples servers. How many UT99 servers are there out there?
     
  17. socamx macrumors 6502

    Joined:
    Oct 7, 2004
    #18
    I'd just stay with the 436 patch, there really is no good point for a Windows machine to patch to 451. Compatibility issues alone make me say this.

    It runs alright, do yourself a favor and download ATi Displays and turn on vsync for UT.

    I run it 1024x768 with 4x FSAA, 16x AF and vsync on (all via ATi Displays) with all possible effects in game running. I get a solid 75 FPS (capped by vsync) most cases. Running on a Dual 1.8 G5 with 1280 MB of ram and a Radeon X800 XT.

    Preview here if interested on how it looks.

    Apple did some OpenGL updates and fixed a few rendering issues, looks pretty solid now although there is a lack of detail textures still and still bad texture tearing issues.
     
  18. Maxx Power macrumors 6502a

    Maxx Power

    Joined:
    Apr 29, 2003
    #19
    There is a simpler solution than this. You should go to your power settings in XP and change your power settings to "always on" to disable powerstepping. This is due to the way older games detect CPU speed which it uses as a clock somewhere in the routines. If it detects 800 MHz because your Core Duo is speed stepping just before you enter the game, then it will drop frames to synchronize the timing even though the CPU has kicked into performance mode after game was started.
     
  19. Jeff Hall thread starter macrumors regular

    Jeff Hall

    Joined:
    Apr 10, 2006
    #20
    This didn't work for me. Can you clarify the procedure? Was I supposed to reboot after changing the setting or something?
     
  20. DougTheImpaler macrumors 6502a

    Joined:
    Feb 28, 2006
    Location:
    Central Illinois
    #21
    I thought that 436 on up were all network compatible, since 436 was the final official patch.
     
  21. stanelie macrumors newbie

    Joined:
    Jun 11, 2006
    #22
    A shortcut with "-cpuspeed 1830" can be made to avoid typing the string everytime to launch Unreal Tournament with the right parameter.

    However, I found that this is not at all necessary to play Unreal Tournament flawlessly on my macbook. Just binding the executable to one CPU did the trick.

    I used imagecfg.exe from here ( http://www.robpol86.com/Pages/imagecfg.php ) to modify the exe so that it would use only one CPU each time it is launched automatically.

    Use this string in a command window while in the unrealtournament/system directory : imagecfg -a 0x1 unrealtournament.exe

    Voilà!

    Stanelie
     

Share This Page