Things getting weird (Problems with iTunes, Screen savers, Preview etc...)

Discussion in 'Mac Apps and Mac App Store' started by edesignuk, Oct 17, 2004.

  1. edesignuk Moderator emeritus

    edesignuk

    Joined:
    Mar 25, 2002
    Location:
    London, England
    #1
    This has got me stumped.

    All of a sudden, the built in screen savers no longer work (says the pictures cannot be found, but they are there, I checked), I cannot export pictures from Preview to jpg, and iTunes looks a mess. WTF is going on here!? :confused:

    And yes, I have repaired permissions, a few times!!
     

    Attached Files:

  2. ravenvii macrumors 604

    ravenvii

    Joined:
    Mar 17, 2004
    Location:
    Melenkurion Skyweir
    #2
    LOL, don't tell me that's on your spankin' new iMac G5!

    Hahahahaha... no offense, man, but the iTunes screenshot is hilarious.

    So... yeah, have you tried restarting? I heard it fixes quite a few problems... heh.
     
  3. edesignuk thread starter Moderator emeritus

    edesignuk

    Joined:
    Mar 25, 2002
    Location:
    London, England
    #3
    Yes, the new iMac.

    Yeah, I can't stop laughing :rolleyes:

    Restarting huh? That's a novel idea, I would never have thought of that on my own!
     
  4. Mord macrumors G4

    Mord

    Joined:
    Aug 24, 2003
    Location:
    UK
    #4
    all i can think of is reinstall.

    i get wierd stuff like than on 10.4 but thats to be expected.
     
  5. edesignuk thread starter Moderator emeritus

    edesignuk

    Joined:
    Mar 25, 2002
    Location:
    London, England
    #5
    A reinstall has to be the very last resort, that's a pain in the arse.

    This is Panther 10.3, these problems aren't to be expected on a new iMac with a new install not even a week old! :mad:
     
  6. Phat_Pat macrumors 68000

    Phat_Pat

    Joined:
    May 8, 2004
    Location:
    I Live Where I Live
    #6
    that sucks man..... maybe apple can help you out. I would try calling them.
     
  7. Mechcozmo macrumors 603

    Mechcozmo

    Joined:
    Jul 17, 2004
    #7
    Do 3rd party screen savers work? If they don't, something is REALLY messed up in the Prefs somewhere. But if they do work...well...I dunno.

    Does Safari have its skin?

    Personally, iTunes looks pretty nice like that...:D
    Have you used any software that modifies iTunes (applescripts do count) or installed anything? That really sucks...I feel kinda bad for you...make that really bad.

    If you start off of a OS X disk (you do have backups, right?) does it appear all funky?
     
  8. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #8
    Maybe something on the UNIX side of Mac OS X is messed up. Open Terminal, cd to the root directory ( / ), and do a long directory listing ( ls - l). Are /etc, /var, and /tmp symlinked properly to /private/(dirname)? If the symlinks are bad or missing, recreate them ( ln -s source destination ).
     
  9. crenz macrumors 6502a

    crenz

    Joined:
    Jul 3, 2003
    Location:
    Shanghai, China
    #9
    It's probably a problem with some system files, and you will probably need to reinstall...

    However, as a last idea -- could it be that your hard drive is almost full (ie., less than 5 GB left)? I know your iMac is new, but I'm just wondering. Full partitions cause all kinds of problems on Mac OS X.
     
  10. edesignuk thread starter Moderator emeritus

    edesignuk

    Joined:
    Mar 25, 2002
    Location:
    London, England
    #10
    -Mechcozmo
    Even other Apple screen savers work, just not the ones that use pictures (Abstract, Beach, Forest, Cosmos are the only ones that don't work). No haxies for anything have been installed. Safari looks fine.

    -wrldwzrd89
    Yup, they all look fine.

    -crenz
    Got 110GB free, so it's not that.

    :confused:

    God dammit, I don't wanna reinstall!!!!! :mad:
     
  11. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #11
    Make a new user and see whether the problems occur there.
     
  12. abhishekit macrumors 65816

    abhishekit

    Joined:
    Nov 6, 2003
    Location:
    akron , ohio
    #12
    Well somehow your Quartz 2D engine is messed up. But I am sorry I don't know how to fix it. I guess its implemented by applications.framework. But again, I have no idea how to do anything about it.
     
  13. edesignuk thread starter Moderator emeritus

    edesignuk

    Joined:
    Mar 25, 2002
    Location:
    London, England
    #13
    Tried that, and wouldn't you know it. Same problem there too :(
     
  14. edesignuk thread starter Moderator emeritus

    edesignuk

    Joined:
    Mar 25, 2002
    Location:
    London, England
    #14
    Um, ok, how do you figure that? :confused:
     
  15. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #15
    The problem's not in your home directory then, which I think means that a reinstall might be needed :(

    An archive install is relatively painless.
     
  16. edesignuk thread starter Moderator emeritus

    edesignuk

    Joined:
    Mar 25, 2002
    Location:
    London, England
    #16
    I here by declare my undying love for archive install :eek:
     
  17. edesignuk thread starter Moderator emeritus

    edesignuk

    Joined:
    Mar 25, 2002
    Location:
    London, England
  18. PlaceofDis macrumors Core

    Joined:
    Jan 6, 2004
    #18
    i take it an archive and install fixed it for you then?? glad to hear it, sux having problems with a new computer like that
     
  19. cb911 macrumors 601

    cb911

    Joined:
    Mar 12, 2002
    Location:
    BrisVegas, Australia
    #19
    LOL. nice new macro you've got there edesignuk. :D at least something good did come out of this. :D

    just a shame you didn't have that macro ready for that picture thread where the tables were all b0rked. :p :D

    ha ha. that's so funny... i've never seen such a stuffed iTunes. :D
     
  20. Sharewaredemon macrumors 68000

    Sharewaredemon

    Joined:
    May 31, 2004
    Location:
    Cape Breton Island
    #20
    I know that makes my day!
     

Share This Page