Thunderbolt display remains off after wake from sleep

Discussion in 'Mac Peripherals' started by netvista, Nov 26, 2012.

  1. macrumors newbie

    Joined:
    Sep 4, 2012
    #1
    Lately it happens quite frequently that my thunderbolt display remains off when i try to wake my macbook pro (late 2011) in clamshell mode. There is no response on any of the devices connected to the thunderbolt display.

    When i attempt to wake the MBP with the mouse or keyboard on the MBP itself it just wakes up normally, so it seems that somehow the thunderbolt display loses it's connection to the MBP completely. The only way out from this situation is a reboot.

    I've changed the setting on the MBP to use only the ATI card, but it makes no difference.

    Any advice on this?
     
  2. macrumors 6502a

    wlossw

    Joined:
    May 9, 2012
    Location:
    Montreal, Quebec, Canada
    #2
    Do you use gfcardstatus to manage your gpu?
     
  3. netvista, Nov 29, 2012
    Last edited: Nov 29, 2012

    thread starter macrumors newbie

    Joined:
    Sep 4, 2012
    #3
    No, but i tried turning off automatic graphics switching in the power settings. With this setting disabled it will only use the ATI card. However, the problem still exists.

    Seems a bit weird that this problem occurs despite using the thunderbolt display, as these 2 products are actually made to work together. With a 3rd party display i could imagine if there would be some compatibility issues, but with this combination...

    But looking at the lack of response on this subject i guess i am the only one with this problem?
     
  4. macrumors 6502a

    wlossw

    Joined:
    May 9, 2012
    Location:
    Montreal, Quebec, Canada
    #4
    I have a different mac, but I was having a similar problem when I forced the use of integrated gpu. Why don't you try switching the gfx card when you plug in the TBD?
     
  5. thread starter macrumors newbie

    Joined:
    Sep 4, 2012
    #5
    That's exactly what i did..i am forcing the MBP to use only the gfx card by disabling the integrated GPU ... But either enabled or disabled, the issue still exists.

    This happens by the way with the TBD connected to the MPB all the time. So basically what happens is:

    - Working @ MBP with TBD attached
    - Finished working => Put MBP to sleep
    - Resume working @ MBP => TBD remains off
    - Open lid on MBP & login => Display settings does not show TBD at all
    - Reboot => Display is recognised and comes on normally after reboot
     
  6. macrumors 68020

    Acorn

    Joined:
    Jan 2, 2009
    Location:
    macrumors
    #6
    Ive had problems with external displays in clamshell but only on battery. if running on battery the external display wont wake up. using ac power everything is fine.
     
  7. macrumors 6502a

    wlossw

    Joined:
    May 9, 2012
    Location:
    Montreal, Quebec, Canada
    #7
    Ok, try installing GFXcard status app. available at

    http://gfx.io

    Then when your monitor stops working, try switching to integrated only and then to discrete only. If this works, then switch to dynamic.

    Let me know if that works for you, as using this utility works differently then OS/X preferences.

    Good Luck!
     
  8. netvista, Dec 7, 2012
    Last edited: Dec 10, 2012

    thread starter macrumors newbie

    Joined:
    Sep 4, 2012
    #8
    Edit:

    Yesterday it happened again, so i'm afraid i have to call apple support for this. :(
     

Share This Page