Ti Powerbook G4 battery "not connected"

Discussion in 'PowerPC Macs' started by orinocho, May 30, 2006.

  1. orinocho macrumors newbie

    Joined:
    May 30, 2006
    #1
    Hello.

    The Mac in question is a 877mhz 15" Powerbook G4 DVI.

    The problem I have with it is that the battery is not being recognised properly. The computer will only boot when mains powered and then the battery status monitor claims to be "calculating... until full". The indicator light on the power jack glows orange making me think the battery is charging untill about 15 minutes later I get the battery icon with an x in it in the status bar and I am told that there are "no batteries available".

    I have tried a PMU reset and a PRAM reset neither of which did any good.

    I should try and test another battery in my Powerbook to see if that fixes it unfortunately I know nobody with an battery I could borrow and have been too lazy to get to the Apple store to ask politely if I could check with one of theirs.

    So before I trundle into central London I was wondering if I have missed anyhting, is it more likely to be the PMU that is at fault? Many thanks for your help in advance.

    Richard
     
  2. superbovine macrumors 68030

    superbovine

    Joined:
    Nov 7, 2003
    #2
    You tried reseating the battery right? Battery is probably bad either way your'll have to goto the apple store to get a battery unless you just order it.
     
  3. orinocho thread starter macrumors newbie

    Joined:
    May 30, 2006
    #3
    Yes, it was the first thing I tried. I should have mentioned that when I tried this when the Powerbook is on it recognises there has been a change and starts calculating until full again only to end in the same no batteries available state.
    Thanks anyway though.
     
  4. superbovine macrumors 68030

    superbovine

    Joined:
    Nov 7, 2003
    #4
    Well I figured you did, but it never hurts to ask. ;)
     

Share This Page