TiBook dead (low battery force sleep deal), help!

Discussion in 'PowerPC Macs' started by Plymouthbreezer, Feb 16, 2006.

  1. macrumors 601

    Plymouthbreezer

    Joined:
    Feb 27, 2005
    Location:
    Massachusetts
    #1
    TiBook (specs in sig) has been great until yesterday - Force sleep due to low battery, now it won't turn back on. Tried resetting power but the little yellow button on back, took out extra RAM, ran off A/C power (batter charged all night, but still showing blinking green indicator light) with and without battery in slot - nothing. Tried the command-control-power thing. Nothing has worked. Gah, terrible feeling.

    Any suggestions? Pleassse help. My mother is going to be super angry if this thing is broke, considering I only got it a few weeks ago. :eek:
     
  2. macrumors 68020

    Joined:
    Feb 12, 2005
    Location:
    VA
    #2
    Try resetting the PMU:

    Link

    PowerBook G4 and PowerBook G4 (Gigabit Ethernet)

    1. If the computer is on, turn it off.
    2. Press and release the reset button located on the rear panel of the computer between the external video and modem ports.
    3. Wait 5 seconds.
    4. Press the Power button to restart the computer.​
     
  3. thread starter macrumors 601

    Plymouthbreezer

    Joined:
    Feb 27, 2005
    Location:
    Massachusetts
    #3
    Already did that. About 20 times. Nothing.
     
  4. macrumors 6502a

    Jschultz

    Joined:
    Mar 14, 2005
    Location:
    Chicago, IL
    #4
    Isn't there a PMU battery? That may have given up the ghost. With the same 'book as you, I suspect this may be a lead.
     
  5. thread starter macrumors 601

    Plymouthbreezer

    Joined:
    Feb 27, 2005
    Location:
    Massachusetts
    #5
    Is this the internal battery?
     
  6. macrumors 6502a

    Jschultz

    Joined:
    Mar 14, 2005
    Location:
    Chicago, IL
    #6
    Yessir.
     
  7. thread starter macrumors 601

    Plymouthbreezer

    Joined:
    Feb 27, 2005
    Location:
    Massachusetts
    #7
    Where is that located?
     
  8. thread starter macrumors 601

    Plymouthbreezer

    Joined:
    Feb 27, 2005
    Location:
    Massachusetts
    #8
    Humm... After reading... I think maybe my power adapter is dead? That would explain the dead battery (which was holding a 5 hour charge two days before... seems unlikely that it would just die so fast). I've plugged it in all night, and nothing happens to the battery.

    I read that if plugged into the A/C power with the battery removed, the sleep light will blink if your internal battery is low (plugging in the A/C overnight with the battery removed would charge the internal battery - at least enough to start the machine up off A/C power, but I don't get a blinking light when I did this). I'm not sure how true it is, but this would also prove my theory of a dead A/C adapter.

    Tomorrow I'll see if my friends iBook (Apple's site says it will work with the older models) power brick charges my battery, or at least will start the TiBook up running off it. I just hate not knowing even what the issue is. :(


    As for the internal battery, how much do those run, if that turns out to be the issue?
     
  9. macrumors 68040

    California

    Joined:
    Aug 21, 2004
    #9
    I had the same computer. The motherboard battery -- located under topcase above optical drive -- went out on mine on the machine's four year birthday. 70 bucks for new one unless you can find a used topcase that has one. Also, I thought it maybe had to do with the 10.3.9 update I had done on the machine the night the machine died, but have no way of knowing. You probably have the old yo yo adapter so you cannot tell if there is actual power going to the machine or not -- no yellow power indicator light, right?
     
  10. thread starter macrumors 601

    Plymouthbreezer

    Joined:
    Feb 27, 2005
    Location:
    Massachusetts
    #10
    That's correct, no yellow light.
     
  11. macrumors 65816

    Sweetfeld28

    Joined:
    Feb 10, 2003
    Location:
    Buckeye Country, O-H
    #11
    Hey Plymouth,

    Did you figure out what the issue was? I feel bad, that something happened to it. My friend who sold it to me, before you bought it from me, told me the battery was bought from OWC [it was an extended life battery - should have a longer than normal battery life].

    I don't know what, other than that, that i could tell you. I, nor my friend, had ever had any issues with it. Let me know if you would like me to ask him anything, as i will relay the messages.


    Ryan
     
  12. thread starter macrumors 601

    Plymouthbreezer

    Joined:
    Feb 27, 2005
    Location:
    Massachusetts
    #12
    Turns out it was the "YoYo" power adapter. I guess it's just dead. The battery still holds a 5 + hour charge.

    I plugged an AlBook's brick in it and it started up just fine. Now I just need to figure out a way to buy the $80 brick without telling my mother! :eek:
     
  13. macrumors newbie

    Joined:
    Feb 22, 2006
    #13
    get on ebay im sure you could find one there cheaper than eighty bucks.
     

Share This Page