1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

tibook no longer turns on...

Discussion in 'Macintosh Computers' started by g30ffr3y, Dec 13, 2004.

  1. macrumors 6502a


    ive got a 1ghz tibook superdrive that ive
    had for just over 2 years...

    for the last few weeks its been acting a bit
    strange by going to sleep while there is still
    an hour on the battery... pretty weird but
    i planned on doing a clean install so i figured
    i would just worry about it then if it kept up...

    anyways... last night i put it to sleep when
    i went to bed and this morning it just wont
    turn on... i tried with the charger plugged in
    and it still wouldnt power... i let it charge for
    a while and it still wont power...

    i have apple care... so do i take it to the
    retail store or do i have to call? what
    kind of hoops can i expect apple to jump
    me through to get this rectified?

    thanks guys...
  2. macrumors 6502a


    no one has ever had to deal with apple care?
  3. Guest


    Something you could try:

    Pop out the battery and disconnect from the mains, let the internal battery run down (for about 30 mins) then plug the mains in and try and power it up without the battery, if it works, try it with the battery in and see if it works.

    My Ti 667mhz did this i did the above and it worked perfectly. Needs a new battery though.
  4. macrumors 6502a



    thanks for the tip... i will try that when i get home from work...
    otherwise i guess ill call apple care... i was just wondering about
    how much of a hassle this will be... this is a really crummy time
    for me to be without my powerbook...
  5. macrumors 65816


    have you tried reseting the PMU? Its a little button on the motherboard you should be able to see when you lift the keyboard out, near the top right corner of the board. Be sure to ground yourself on the tibook's case first and i'd recomend using a pen to press the button itself. You may hear a slight noise when you press the button, and you will lose your date and time settings, but that has helped me when i couldn't get my tibook to boot.

Share This Page