Tiger: How do I get am/pm to show?

Discussion in 'macOS' started by TMA, Jan 8, 2006.

  1. TMA macrumors 6502a

    TMA

    Joined:
    Jan 6, 2003
    Location:
    England
    #1
    Hi all, first i'll just say i've done a few google searches and checked the forums for an answer to this but with no success.

    I really struggle with 24-hour time format and I can't find a way to enable the am/pm option that I used to use in Panther. It's there in Date & Time preference pane but its greyed out. Does anyone have any ideas how to sort this out? It's been troubling me for some time now.
     

    Attached Files:

  2. J@ffa macrumors 6502a

    J@ffa

    Joined:
    Jul 21, 2002
    Location:
    Behind you!
    #2
    You're set to 24 hour clock! :p

    Don't worry, I did that too - it drove me ballistic figuring out why it wasn't showing!
     
  3. TMA thread starter macrumors 6502a

    TMA

    Joined:
    Jan 6, 2003
    Location:
    England
    #3
    :eek: wups - How have i missed this little option for so long?!

    I've unchecked use 24 hour clock, but it's still not showing am/pm in the menu bar and the option to allow it is still greyed out.
     
  4. PlaceofDis macrumors Core

    Joined:
    Jan 6, 2004
    #4
    very odd. i can select any combo of options and not have it grey out.

    perhaps toggle the 24hour clock off, quite System Prefs and then reopen to see if its available, if not i would try logging out and back in.

    i suppose repairing permissions wouldn't hurt either.
     
  5. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #5
    Go to the international pane, and click on the Customize next to the time. Make sure you have the AM/PM element showing up in the white box, and make sure labels exist for AM and PM.
     
  6. J@ffa macrumors 6502a

    J@ffa

    Joined:
    Jul 21, 2002
    Location:
    Behind you!
    #6
    Ok, go to System Preferences --> International (at the top, under personal) --> Formats, and then click the 'Customise' button next to 'Times'. You can set up the time display however you like from there. :)
     
  7. PlaceofDis macrumors Core

    Joined:
    Jan 6, 2004
    #7
    ah you probably have got it right there.... i didn't realize you had those options in that preference pane.
     
  8. TMA thread starter macrumors 6502a

    TMA

    Joined:
    Jan 6, 2003
    Location:
    England
    #8
    Ahhh found it!!! turns out I had enable the AM/PM indicator in all time formats, buried deep within the International preference pane.
     
  9. Applespider macrumors G4

    Applespider

    Joined:
    Jan 20, 2004
    Location:
    looking through rose-tinted spectacles...
    #9
    It seems to be something to do with non-US setups that makes the option grey out.

    One thing to bear in mind when you're customising the time in International Preferences, it's the Medium format (or occasionally the Long format) which you need to change in order to have it switch in the menu bar. Changing the 'Short' one will have no effect.
     
  10. skunk macrumors G4

    skunk

    Joined:
    Jun 29, 2002
    Location:
    Republic of Ukistan
    #10
    It seems you have to set the format to US (and then adjust the currency, etc). Odd.
     
  11. TMA thread starter macrumors 6502a

    TMA

    Joined:
    Jan 6, 2003
    Location:
    England
    #11
    Well now that i've set am/pm indicators for all time formats (Short, Medium, Long and Full) in the International pane, its now allowing me the am/pm option in Date & Time.

    Did not have to change to US format.

    Phew that was just a bit long winded!
     
  12. Applespider macrumors G4

    Applespider

    Joined:
    Jan 20, 2004
    Location:
    looking through rose-tinted spectacles...
    #12
    Go into the Customise panel that you posted above and click on the Time one.

    Change it to 'Medium' in the drop down box and then drag the things you want into it... Hit OK and it should update in the menu bar (tho might take a few seconds)

    EDIT: You've fixed it in the meantime :p
     

    Attached Files:

  13. neocell macrumors 65816

    neocell

    Joined:
    May 23, 2005
    Location:
    Great White North
    #13
    Don't really want to hijack the thread, tell me to piss off if this annoys you and I'll start a new thread, but does anyone know how to get the day of the month (number) displayed with the time? I currently use MenuCalendarClock to do this but would prefer another way. Thanks
     
  14. Applespider macrumors G4

    Applespider

    Joined:
    Jan 20, 2004
    Location:
    looking through rose-tinted spectacles...
    #14
    Just do a quick search - this came up less than 24 hours ago.

    In summary though, go to International Preferences, go to Customise Date in the Format section, switch it to Medium format and get the fields you want into the smaller box by dragging them there, do a Command A to select all and then Command C to copy. You don't have to hit OK to save them.

    Then go into the Time format, change it to Medium format and do a Command V to paste the date format into the Time box. You can use the cursor to delete the year or AM/PM if you like. Hit OK and it should appear up there.
     
  15. neocell macrumors 65816

    neocell

    Joined:
    May 23, 2005
    Location:
    Great White North
    #15
    Thanks a lot, sorry for being a lazy jerk and not searching first, your info worked liked a charm
     

Share This Page