Time always wrong when booting between OSX/Vista

Discussion in 'Windows, Linux & Others on the Mac' started by zakatov, Dec 8, 2006.

  1. zakatov macrumors 6502a

    zakatov

    Joined:
    Mar 8, 2005
    Location:
    South Florida
    #1
    So after I installed Vista RTM, every time reboot into another OS (X->Vista, Vista->X), the time is always wrong. Has to be firmware-related, any ideas??
     
  2. ghall macrumors 68040

    ghall

    Joined:
    Jun 27, 2006
    Location:
    Rhode Island
    #2
    I believe it has something to do with how Mac OS X reads time, and how Windows reads time. I'm not sure about the specifics, but it is definitaly NOT firmware related, it's definitaly OS related.
     
  3. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #3
    OS X, like Unix, expects the system clock to be set to GMT. Windows expects it to be set to local time. Chaos ensues.
     
  4. bearbo macrumors 68000

    bearbo

    Joined:
    Jul 20, 2006
    #4
    then how to deal with this?
     
  5. Westside guy macrumors 601

    Westside guy

    Joined:
    Oct 15, 2003
    Location:
    The soggy side of the Pacific NW
    #5
    When I adjusted the time during XP setup, I ran into this problem. The second time around I left the (incorrect) time alone, and just told XP to sync with a time server - then it worked okay on both XP and OS X.

    Not sure how to change whatever that did in an existing install of XP though.

    Edit: Apple basically says "use a time server on both OSes" - see the FAQ note here (about the fifth item down)
     

Share This Page