*too slow* Vertex 3 in 13" MacBook Unibody late 2008

Discussion in 'MacBook Pro' started by SpaceDoc, May 18, 2011.

  1. SpaceDoc, May 18, 2011
    Last edited: May 23, 2011

    macrumors member

    May 18, 2011
    *now fast* - read thread further down for the solution of the problem! ;)
    (and the stony way towards it :))

    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

    Hi everybody,

    and hopefully you will be able to help me further! ;-)

    I recently updated the HDD of my 13" MacBook 2.4 GHz Unibody 'late 2008' to a SSD: a 240 GB Vertex 3. ;-)

    But now I realize that although this is a SATA-3 (= 6 Gigabit 'Link speed') enabled SSD which should be downward compatible to SATA-2 (like as to my knowledge my MacBook should support) and therefore negotiate SATA-2 (=3 Gigabit 'Link speed') for data exchange with my Macbook it actually only communicates at SATA-1 (=1.5 Gigabit 'Link speed') level with my MacBook. [see image 1st attachment]

    I think my Macbook's EFI / Firmware is up to date. [see image 2nd attachment] - but please correct me if I am wrong.

    What can I do to make my Vertex 3 perform at SATA-2 (= 3 Gigabit) speed in my MacBook? Help very much appreciated!

    Thanks in advance!

    edit: added 'problem solved'! ;-)

    Attached Files:

  2. macrumors G4


    Mar 24, 2006
    Have u done an SMC reset?

    Also getting the Vertex 3 for a non SATA 3 interface is just a bad idea it simply won't perform as well because they need the S3 interface. I'd suggest a Vertex 2 or any other SATA2 Sandforce (or Intel) drive.
  3. thread starter macrumors member

    May 18, 2011
    thx for the input!

    no. how to do that?

    I already have that SSD ... :( ...
    ... off course I am aware of that it would not perform at SATA-III level. but SATA should be downward compatible therefore a SATA-III device should perform SATA-II on a SATA-II device! not SATA-I performance, I'd say. No?
  4. macrumors G4


    Mar 24, 2006
    Yes you should definitely be getting SATA3 at least.

    To perform an SMC reset for your model. Shutdown the computer, disconnect all peripherals and remove the battery. Then press the power button for 5s (i do 10s just to be safe).

    Put the battery back in, connect everything back and boot the machine as per normal.
  5. thread starter macrumors member

    May 18, 2011
    thx 4 detailed explanation, very much appreciated!!
    I'll do this right now ... =;-o
  6. thread starter macrumors member

    May 18, 2011
    Didn't help ... :( ... same situation as before:
    - Link Speed = 3 Gigabit
    - Negotiated Link Speed = 1.5 Gigabit

    :( :( :(
  7. macrumors G4


    Mar 24, 2006
    Hmm...weird. Try a PRAM reset too. Reboot your mac and whilst booting hold down Command+Option+P+R simultaneously (probably better to start this finger salute combo once you click restart). Keep holding it till you hear a second, louder chime then let go.

    IF that doesn't work then RMA the drive.

    PS- Did you clone your old drive onto the Vertex or did you do fresh install?
  8. thread starter macrumors member

    May 18, 2011
    No change! :(
    [thx again for the detailed 'how to' - very much appreciated!!!]

    Fresh install! :) From the Scratch!
  9. daneoni, May 18, 2011
    Last edited: May 18, 2011

    macrumors G4


    Mar 24, 2006
    Then the problem is hardware. Either the SATA connection of your macbook or the drive itself.

    I also have the same Vertex 3 model and mine is recognized...granted our chipsets are waay different but still i'm surprised you're not even getting SATA2

    Attached Files:

  10. thread starter macrumors member

    May 18, 2011
    first let me express my thanks for all your efforts, mate!

    googling around the web in the meantime found some more 'statements': there may be a problem in the cooperation between this SSD and the MacBook with an Nvidea Chipset. :( Although: those reports are not consistent ... sometimes it works, sometimes not!

    although I have to admit: I am deeply shocked by this product (OCZ) which I had asumed to even be a top of the line higher quality one. I mean: of course there's not to expect a SATA-III performance as the MacBook only is SATA-II. But SATA-II should be the result of negociations.

    as OCZ does not provide a Firmware Update Tool for Mac OS X :( I just too out my SSD and attached it to my old Windows XP Notebook through an external SATA-to-USB-device. The Firmware Update Tool of OCZ kept on telling 'no OCZ device attached' while the Windows Explorer right clicked on the external drive clearly stated the OCZ Vertex 3 SSD! :( :( :( So I even have no clue how to update the Firmware of that SSD! :( :( :(

    I am currently very frustrated and dissatisfied with this product!!!
    [but still looking for a happy end! :) ]
  11. macrumors G4


    Mar 24, 2006
    I think i read somewhere that the drive must have an NTFS/FAT partition on it for the update to work in windows because Windows can't read HFS+ (im not sure of this). Also i think there are two Nvidia chipsets out there...one for the 9400m (MCP79) and another for the 320m (MCP89). The 320m models might be the ones working whilst the older 9400m might be the ones with issues. Although i'm only guessing here.

    If i were you i'd return it and get an Intel 320 or 510 series drive. You can do FW updates on OS X machines and people seem to generally be happy with them. That, or revert to SATA II SSD till you get a newer Mac.
  12. thread starter macrumors member

    May 18, 2011
    I actually have a second partition on that SSD. FAT-formated [though no further content on it]. Do you think I should copy those OCZ files onto it while on the USB-connection and only then start the OCZ-utility? Sound a bit strange, doesn't it?

    Unfortunately it's too late to return the SSD. And in Europe it's not all that easy anyway. So I will have to continue with this one. [and I will not buy another aluminium MacBook(Pro) before I can get an 11" MacAir with high-res non-glare (!) screen and Core-i ;) ]

    thx again!
  13. macrumors G4


    Mar 24, 2006
    No because it's best to run the utility separate from the Vertex itself. Maybe format to NTFS and try again.

    Sell it? A lot of people still want one.
  14. thread starter macrumors member

    May 18, 2011
    would that be the same, after copying it to the SSD? and run it from there, although on the USB-2-SATA-adapter?

    why should NTFS make a difference?
    also: not possible ... MacOSX is unable ot format NTFS. :(
  15. macrumors G4


    Mar 24, 2006
    As in you have to run the utility from a separate volume (different drive) to the SSD

    I'm not sure it does but its worth a short. Use the XP you're booting from to reformat that partition to NTFS.
  16. thread starter macrumors member

    May 18, 2011
    that's what I though intitially ... and what - of course - should be right.
    but as the whole OCZ stuff 's*cks* anyway I gave it a da*n try ...
    ... of course it failed! :(

    but why should this help? the OCZ-FW-update-utility just has so recognize the OCZ-device (which (even) windoze does but OCZ utility not!) - I don't think that NTFS vs FAT would make a difference. and anyway: shouldn't FAT be more 'compatible' in general thinking anyway??
  17. macrumors G4


    Mar 24, 2006
    It should but now its down to one of those 'i'm willing to try anything moments however ridiculous" if i were in your shoes.
  18. thread starter macrumors member

    May 18, 2011
    true!!! :( :( :( :( :(
  19. macrumors 68000


    Feb 26, 2011
    I'm sorry for your troubles but I think I can help. Here's a few things you need to know.

    First, you can not upgrade the firmware over a USB connection. It will not work.

    Second, you can't upgrade the firmware if you have booted from any partition on the ssd.

    Third, afaik, it doesn't matter what boot loader, file system or partition is on it. The update tool doesn't care about any of those things.

    So, the easy way to do it is to get another computer and boot to Windows or Linux with the SSD connected via a SATA cable. The tool should work fine than. Or, you can try a Windows or Linux live cd booting your MacBook but the reports are mixed on that. I'm not sure if it would work on a 2008.
  20. thread starter macrumors member

    May 18, 2011
    did *not* help! :(
  21. thread starter macrumors member

    May 18, 2011
    thx, dustin!!!

    conc. 1: stupid, isn't it, for a 2.5" notebook hdd device (if they do not offer a native Mac OS FW-update tool!)

    conc. 2: that's what I originally expected ... but at a certain moment you start to try anything. (and I am quite pi**ed off by now!)

    conc. 3: that's also what I expected ... but check point 2! :)

    conc. your 'easy' way: there's no stupid windows computer with such a hardware around any more! MacBook late 2008 unibody, 2x MacMini, 1x Toshiba M200 WinXP Tablet PC Edition Notebook .. that's it! :)

    first OCZ product ... and probably the last!!! :( :( :(
  22. macrumors 68000


    Feb 26, 2011
    Ya, OCZ isn't going out of their way to make this easy for Mac users. I will say the BIOS\EFI on your MacBook is probably the limitation here. You may have better results if you install the SSD in your Toshiba and boot off a Linux live cd. There's a simple fwupd tool for Linux that finally worked for me when I tried it on another computer.

    I know its not the easiest way in the world but it will probably work.
  23. thread starter macrumors member

    May 18, 2011
    The Toshi is pre-S-ATA times: P-ATA! :(

    Now I even lost a little screw of the MacBook case ...
    ... I am completely pi**ed off!

    This Vertex 3 should be a premium product, not something that completely s*cks! Not only that the 'fall back from SATA-III to SATA-II does not work ... but also that their FW-update can neither be performed on a Mac nor through an external HDD enclosure. And even their Windows-FW-Update s*cks! Actually: download their FW-update ... even NO clear 'readme.txt' or any usefull general instructions! One has to blindly start the .exe-file! :( Bad bad bad ...

    'quality will be remembered when the price has been long time forgotten' ...
    ... but also ...
    'bad experiences will be remembered (nearly) eternaly'!

    at the moment I fear: first OCZ but last OCZ product. Ever!
    and I will not recommend it in my photographic forums!
  24. macrumors 68000


    Feb 26, 2011
    Its a shame you feel that way. The OCZ ssd's are really market leading. At this point you can live with it or ask an understanding friend to allow you to borrow his pc for a few minutes.

    Best wishes!
  25. thread starter macrumors member

    May 18, 2011
    Hmm ...
    ... not adequate SATA-III to SATA-II fall-back you call 'market leading'???
    ... having NO Mac OS X FW-update-utiliy you call 'market leading'???
    ... having NO boot from burned ISO-image and update firmware you call 'market leading'???

    man: we are living in the 11th year for the 21st century!!!

Share This Page