Trouble burning CDs

Discussion in 'Macintosh Computers' started by uhlawboi80, Jul 20, 2003.

  1. macrumors 6502

    ok, i had been having a few problems burning CDs from iTunes, but it normally would let me burn one if i closed it and told the "blank disk" box to open iTunes.

    NOW it simply wont allow me to burn a CD. no matter what i do, i get Disc Burning failed because of an unknown error occured (0x80020022). Anyone have any idea what i could do to fix this? I repaired permissions and other basic things to see if it was a simple software issue...but nothing. Could this be a hardware issue?? I also tried MANY blank CDs, of different types. Rather lovely that it can only produce an UNKNOWN error:rolleyes:
  2. macrumors 6502a


    Can you burn cd's in other applications like Disc Copy or Roxio Toast? If so, it could be a problem with iTunes. If not, make sure that the cord connecting it to the computer isn't loose. I'll try to be all the help I can be, but I'll admit I've never seen an error like that.
  3. macrumors 68030


    looks like a device error to me, and are you using any plugins for iTunes?
    I would contact Apple Support for more info on the error.
  4. macrumors 6502

    well the drive works as far as playing CDs/DVDs and i just ripped a few CDs etc...but i just tried to burn a small data CD to make sure that it would still burn data CDs....and when it goes to verify the CD is says "sorry, the operation could not be completer because an unexpected error occured (error code 6)" and THEN the dialogue box that says "youve just inserted a blank CD" reappears...HMMMM, it may be hardware.
  5. macrumors 6502

    well ive done everything software wise that i can think to unless anyone has a better idea, i guess i will be taking it to the apple store tommorow to be looked at...just hope its covered by he warranty.
  6. ajp
    macrumors member


    Hope you don't mind me jumping in on your thread but I too am having problems burning CDs. I have an IMac with up to date software but suddenly can't burn CDs. Been trying all day with a stack of new and different CDs. iTunes goes through the motions then spits out the disc with a "burning failed because of a disc failure" message. I tried Disc Copy with a variety of information and keep getting "Error 6" as well. I did manage to copy one music CD but, although it's data showed up on iTunes, the desktop shows it to still be blank. Needless to say it doesn't play on my stereo!

    Since my last successful CD burn, I have (in error) tried copying files onto a DVD+R. Could this have upset it all? I'm going to have to leave it now or the whole lot is going out the window. I'm not on the ground floor.
  7. macrumors newbie

    I am having the same problem!!!

    That stupid Error 6 thing. I used to get it when I was running in OS 9.2 in iTunes, and I am having the same problem in OS 10.2.3. Argh. I was trying to back up all my stuff onto cd's before installing the Jaguar upgrade, and it was taking forever b/c of problems during burning. During the verification stage I would get an error 6. I'd eject the cd-rw, reformat, and after a couple of times I would get a successful burn.

    Has anyone found a solution to this problem yet?
  8. macrumors member

    I've been having the same issues with iTunes. Using Toast, I can burn discs that had just been rejected by iTunes.
    It gives me the same error message, then spits out the disc. Tried repairing permissions (which did repair some iTunes bits) but to no avail.
    Toast is great but it would be nice to be able to just grab stuff out of my iTunes playlist on the fly and burn away.


    btw - I'm using an external Lacie 52x CD burner with a Pismo PB running 10.2.6
  9. macrumors newbie

    Mine's an internal CD-RW. I'm going to head over to the Apple Store this weekend and inquire...I'm under the extended AppleCare warranty so I should be good if it needs repairs. If they tell me something pertinent I'll pass it along to you guys.
  10. macrumors newbie

    What is the second gap between songs set to?, found this on apple's discussions, and it fixed most peoples problems:

    The song gap under iTunes/Preferences/Burning has to be 2sec with the Firewire versions of the LiteOn LTR-52246S & Mitsumi CR-487ETE that LaCie has used of late.

    This thread may help
  11. macrumors 6502a


    Uhlaw, Offtopic, but Bill Maher is the smartest guy I've seen. Finally I can see some people besides me appreciate his thought of and on all sides.
  12. macrumors newbie

    My error 6 problem seems to have been cleared up. I upgraded my system from 10.2.3 to 10.2.6 and so far have been able to burn three different cd's without a hitch. One was an iTunes cd, another a HD backup cd, and the last a copy of some images for a friend. I had no problems whatsoever.

    I was going to take a trip to the Apple Store but felt I didn't have a reason to. If my computer acts up, I'll take it in.

    I don't know what systems you guys are running, but it would be worthwhile to consider upgrading to the most latest OS since X (10.1) has a lot of bugs. In doing that, some software should be updated as well.

    filmcutter- Have you looked into any patches for your external burner? I had to get patches for both my epson printer, and epson scanner to be able to work with Jaguar.
  13. macrumors 604


    sounds like a possible corrupt preference. i would delete the itunes prefrences, if that doesnt work try reinstalling itunes all together. if you dont have toast go to and download a program called firestarter, its free to try out. i use it to burn all my bin files. if it burns just fine then its probably just itunes.

  14. macrumors newbie

    What fixed my problem

    I wasn't satisfied with the 650 mb suggestions I have read or buy the
    expensive cd answer because I had already used cheap 700 mb to
    burn. So I quote my post on another forum....

    I saw somewhere that someone had tried buying one of
    those cleaning cds with the little brush on it. Went and
    got one at the local drug store for 10 bucks. Ran it
    and everything started working fine. May not work
    for everyone but its only 10 bucks.

    Hope it helps

Share This Page