Trouble during tedious rebuild of my iTunes library

Discussion in 'Mac Applications and Mac App Store' started by Sossity, Jul 28, 2013.

  1. macrumors 6502a

    Joined:
    May 12, 2010
    #1
    I recently lost my whole itunes library, & have been slowly rebuilding it, by re adding all my music, but for a couple of albums, I get a red stop sign error message saying it cant copy to music disk, the file is in use, & iTunes will not place them in the library.

    I have made an attachment screen shot to show what is happening. what could be causing this? I ran a disk permissions, & it helped with a few other albums, but there are still some that are stubbornly not loading into my new library.
     

    Attached Files:

  2. macrumors G5

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #2
    Have you tried resetting the SMC?


    http://support.apple.com/kb/ht3964
     
  3. macrumors 65816

    Partron22

    Joined:
    Apr 13, 2011
    Location:
    Yes
    #3
    Can you duplicate the troublesome album folders in Finder?
    If so, have you tried adding the duplicate files rather than the originals?
     
  4. thread starter macrumors 6502a

    Joined:
    May 12, 2010
    #4
    I tried the SMC reset, it did not work, I am using the music volume in an esata dual bay enclosure, & perhaps the esata is not working well with my mac mini, or maybe those individual folders are corrupt?

    @Partron22, I tried copying the troublesome albums from my external to my mac, & then tried to load them into itunes, & got the same thing, it seems to think something or someone is using them.
     
  5. macrumors 65816

    Partron22

    Joined:
    Apr 13, 2011
    Location:
    Yes
    #5
    You have admin privileges?
    Do a Finder 'Get info' on one of your copied files, 'Sharing & Permissions', and make sure everyone's got read and write privileges. Those do sometimes get screwed up.

    You HAVE rebooted by now, I hope?
     
  6. Sossity, Jul 29, 2013
    Last edited: Jul 30, 2013

    thread starter macrumors 6502a

    Joined:
    May 12, 2010
    #6
    Yes, I have rebooted, I have since shut down & powered up since this post.

    Edit; checked the permissions for those albums, & it said I had read and write.
     

Share This Page