Trouble with external hard drive

Discussion in 'Mac Basics and Help' started by sabre, Dec 21, 2006.

  1. sabre macrumors newbie

    Joined:
    Dec 21, 2006
    Location:
    Japan
    #1
    Hi, I am having some problems with my external hard drive. I have a Logitec 400 GB. It is quite new (one month or so), and it was working fine until last week. I use it mainly for media and backup. Well I have searched for solutions and finally decided to make a post. When I plug it into my USB port it doesn't show up in Finder or Disk Utility. Also when I plug into my firewire port it doesnt show up in Finder. When I go to disk utility it automatically says "Gathering disk information" and it has been doing this for hours. When my external hard drive was working I always used the firewire port. There is nothing wrong with my USB ports as they support my MP3 player printer etc. Please if anyone can help I would be most greatful.
    Thank you
     
  2. jeremy.king macrumors 603

    jeremy.king

    Joined:
    Jul 23, 2002
    Location:
    Fuquay Varina, NC
    #2
    If neither port is working, it sounds like the enclosure might have died. You can test by putting a known working drive inside it and test or you could always go buy another enclosure or get the original replaced by Logitech.
     
  3. sabre thread starter macrumors newbie

    Joined:
    Dec 21, 2006
    Location:
    Japan
    #3
    thanks kingjr, Thanks for your response. Seems strange that the hard drive died so quickly!? Would there be anyway to retrieve what is on the hard drive?
     
  4. jeremy.king macrumors 603

    jeremy.king

    Joined:
    Jul 23, 2002
    Location:
    Fuquay Varina, NC
    #4
    Id suspect its the enclosure, not the drive itself. You can only confirm that by replacing the drive inside the enclosure with a known working drive. If that doesn't work, its definitely the enclosure.

    If you are in need of the files immediately and don't want to hassle with warranty repairs, you should be able to pull the hard drive out of the enclosure and install it into another enclosure. This will help you identify if the drive is dead, too.
     
  5. sabre thread starter macrumors newbie

    Joined:
    Dec 21, 2006
    Location:
    Japan
    #5
    Thank you very much for your time and help. I don't need the files immediately, so I will take it back to the store where I bought it.
    Thanks
     
  6. jeremy.king macrumors 603

    jeremy.king

    Joined:
    Jul 23, 2002
    Location:
    Fuquay Varina, NC
    #6
    Not sure what return policies are in Japan, but they may just direct you to the manufacturer to get it serviced. Good Luck and let us know what they find out.
     
  7. sabre thread starter macrumors newbie

    Joined:
    Dec 21, 2006
    Location:
    Japan
    #7
    Well I will take it back to the store and hopefully they can point me in the right direction...it may be hard with my lack of Japanese though :confused: .
    Thanks again.
     

Share This Page