Trouble with TiBook (GFX?)

Discussion in 'PowerPC Macs' started by SuperCompu2, Aug 16, 2007.

  1. macrumors 6502a

    SuperCompu2

    Joined:
    Jul 23, 2006
    Location:
    MA
    #1
    So my TiBook's been acting up, displaying nothing on the screen at boot-up and making the volume quacks. It also gongs on startup. I tried resetting the PRAM, which worked for about 1 minute till it told me my clock was wrong, then it began twitching the screen with horizontal lines. To top it all off, it doesn't sleep when you close the lid. Special.

    So, this is a really inopportune time for my laptop to crap itself, as school is approaching fast again. Anyone know how to correct this?
     
  2. thread starter macrumors 6502a

    SuperCompu2

    Joined:
    Jul 23, 2006
    Location:
    MA
    #2
    Ok, so I think I narrowed down the problem, and I do think it's the graphics card.

    The screen comes up fine with pressure near the GPU, and when released starts the crazy horizontal twitching. Would the fixes seen on the web relating to the re-heating of solder balls in iBooks work with this as well?
     
  3. macrumors 68020

    noodle654

    Joined:
    Jun 2, 2005
    Location:
    Never Ender
    #3
    Have you run Apple Hardware Test from your CD's? Or maybe even TechTool Deluxe?
     
  4. thread starter macrumors 6502a

    SuperCompu2

    Joined:
    Jul 23, 2006
    Location:
    MA
    #4
    Bought the TiBook used from MR user Grimace, no CDs included.

    How does TechTool Deluxe work?
     
  5. macrumors 68020

    noodle654

    Joined:
    Jun 2, 2005
    Location:
    Never Ender
    #5

Share This Page