Trying to get WakeOnLan to work over the internet

Discussion in 'Mac OS X Server, Xserve, and Networking' started by Demigod Mac, Nov 26, 2012.

  1. Demigod Mac, Nov 26, 2012
    Last edited: Nov 26, 2012

    macrumors 6502a

    Joined:
    Apr 25, 2008
    #1
    Trying to get WakeOnLan ( www.readpixel.com/wakeonlan/ ) to work over the internet, so I can remote wake my Mac Pro from sleep with my Macbook Pro, connect to it via Chicken (VNC) and then put it back to sleep when I'm done.

    Thus far I've been able to get everything working locally on the LAN. Chicken works, WakeOnLAN works.

    If I try it remotely over the internet however, the Mac doesn't wake up. Chicken works over the internet if my Mac is already awake.

    Router is a Linksys E1000. I set my router's subnet mask on 255.255.255.128. I set up my router's port forwarding to 192.168.1.127 (listening port) on ports 7 and 9 for wakeup. Router's firewall is disabled. Is there something I'm missing here?
     
  2. thread starter macrumors 6502a

    Joined:
    Apr 25, 2008
    #2
    It's looking like the reason it doesn't work is that Linksys disabled the broadcast address forwarding feature in recent firmware... Means I might have to go with DD-WRT for this to work!

    If anyone has other suggestions I'm all ears.
     
  3. macrumors 6502

    DJLC

    Joined:
    Jul 17, 2005
    Location:
    Mooresville, NC
    #3
    Not sure what the issue could be off-hand, but I'd say give DD-WRT a shot anyway. Linksys firmware has been pretty crappy as of late.
     
  4. macrumors newbie

    Joined:
    Nov 28, 2012
    #4
    Wake On LAN is local ethernet only. It doesn't work over the internet.
     
  5. macrumors 6502

    DJLC

    Joined:
    Jul 17, 2005
    Location:
    Mooresville, NC
    #5
    Now that I think about it...

    You can do WoL from the DD-WRT interface. Your remote workflow would be something like...

    1) Login to your home router via Safari, use that to wake your Mac.
    2) Connect via VNC, put it back to sleep via Apple > Sleep when you're done. Or just wait for automatic sleep to kick in.
     
  6. thread starter macrumors 6502a

    Joined:
    Apr 25, 2008
    #6
    I got it working. DD-WRT and some heavy duty configuration required.

    If anyone's interested I could try retracing all my steps and post them here.
     

Share This Page