Turning on DMZ in airport

Discussion in 'Mac Applications and Mac App Store' started by johnkrz, Sep 8, 2004.

  1. macrumors member

    #1
    how do i make dmz active i have looked high and low everywhere what do i do.
     
  2. macrumors demi-god

    wrldwzrd89

    #2
    It took some searching, but I found the setting - it's called Default Host rather than DMZ.

     
  3. macrumors member

    #3
    thanks for the help
     
  4. macrumors 68030

    crazzyeddie

    #4
    Has anyone actually gotten this to work? I tried it about 10 times last night, using the directions Apple supplied and even trying DHCP with manual IP, but no joy. I could never establish the IP with the Airport Express. Help :(
     
  5. macrumors 6502a

    psycho bob

    #5
    Well I assume it will work with both Airport Extreme and Express basestations. I've had great problems with DMZ regardless of the router manufacturer.
    When using manual IP addressing make sure you specify the IP address of the router as the DNS server on the mac otherwise you won't get internet access.
     
  6. macrumors 68030

    crazzyeddie

    #6
    You sir, are a genius.
     
  7. macrumors 6502a

    psycho bob

    #7
    Not often I get called that, just glad the info helped. If only I could get some D-Link routers to forward to the correct ports for a client. In some cases I've resorted to setting up 1 computer using Windows ICS (internet connection sharing) and then replaced the actual D-Link router with a switch. Not an elegant solution but it works.
     
  8. macrumors 68030

    crazzyeddie

    #8
    What problem are you having with your D-Link? I had absolutely no problems using both DMZ and Port Forwarding on my D-Link router for over a year.
     
  9. macrumors 6502a

    psycho bob

    #9
    One of the people I work for has had a database (Goldmine) installed recently and the company require remote access to the machine. So I set the server up as the default DMZ machine, assigned it a fixed IP and set up port forwarding and the firewalls to allow access. But nothing happened, the connection coul not be made. To make my life easier I use VNC where possible but despite setting things up as I would normally it just would not make the connection. If I fixed the computer directly to the modem all was well so the problem was with the router. Never had any problems with my airport and what is really strange is when I first set the thing up it worked fine. I came back the next day to finish installing some software and got a phone call from the database people saying they couldn't connect. The ISP they were using then provided a fixed IP so that wasn't the problem, annoying the they have now changed to a ADSL supplier who changes it so I've had to set up a Dynamic DNS account. Hopefully with the router out of the equation things will be ok. Just so you know all the machines in question are winblows machines (XP SP2 - I hate having to work with windows).
     
  10. macrumors 68030

    crazzyeddie

    #10
    On my D-Link, you can set up static DHCP assignment via the router, so you can leave a client computer set to DHCP and the router will assign it the same IP every time (based on the MAC address). Also, if you have DMZ enabled, you should not need port forwarding or firewall, as neither would apply to that computer. The port forwarding should also override any Firewall settings. Try one step at a time.

    Edit: The static DHCP function was added via a firmware update, so make sure you have the latest firmware.
     

Share This Page